summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-09-24 00:01:52 +0200
committerJP Cimalando2018-09-24 00:30:01 +0200
commitca79beb3dbe39dc3305ac6dd1a2e9580a12b812c (patch)
treea15f7947b4b1ab53dcce5b3adacb44e9bac9703c
parent8594da09e7b75449b9aa80a4e42c1fcc473df3a9 (diff)
downloadaur-ca79beb3dbe39dc3305ac6dd1a2e9580a12b812c.tar.gz
make it a split package with opnplug
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD56
2 files changed, 46 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c210fe6561d0..8946547ac029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = adlplug-git
- pkgdesc = FM synthesizer plugin for ADLMIDI with OPL3 chip emulation
- pkgver = v1.0.0.beta.1.r14.03fb745
+ pkgver = v1.0.0.beta.2.r1.b5ac366
pkgrel = 1
url = https://github.com/jpcima/ADLplug
arch = i686
arch = x86_64
+ groups = pro-audio
license = GPL
makedepends = git
depends = jack
depends = alsa-lib
depends = freetype2
depends = libxext
- provides = adlplug
- conflicts = adlplug
source = git+https://github.com/jpcima/ADLplug.git
source = git+https://github.com/Wohlstand/libADLMIDI.git
source = git+https://github.com/Wohlstand/libOPNMIDI.git
@@ -27,4 +25,12 @@ pkgbase = adlplug-git
md5sums = SKIP
pkgname = adlplug-git
+ pkgdesc = FM synthesizer for ADLMIDI with OPL3 chip emulation
+ provides = adlplug
+ conflicts = adlplug
+
+pkgname = opnplug-git
+ pkgdesc = FM synthesizer for OPNMIDI with OPN2 chip emulation
+ provides = opnplug
+ conflicts = opnplug
diff --git a/PKGBUILD b/PKGBUILD
index f075239dcce2..e7c035e78532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
# Maintainer: Jean Pierre Cimalando <jp-dev@inbox.ru>
-pkgname=adlplug-git
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=(adlplug-git opnplug-git)
_pkgname=ADLplug
-pkgver=v1.0.0.beta.1.r14.03fb745
+pkgver=v1.0.0.beta.2.r1.b5ac366
pkgrel=1
-pkgdesc="FM synthesizer plugin for ADLMIDI with OPL3 chip emulation"
arch=('i686' 'x86_64')
url="https://github.com/jpcima/ADLplug"
license=('GPL')
-groups=()
+groups=('pro-audio')
depends=('jack' 'alsa-lib' 'freetype2' 'libxext')
makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-replaces=()
-backup=()
-options=()
-install=
source=('git+https://github.com/jpcima/ADLplug.git'
'git+https://github.com/Wohlstand/libADLMIDI.git'
'git+https://github.com/Wohlstand/libOPNMIDI.git'
'git+https://github.com/jpcima/JUCE.git'
'git+https://github.com/fmtlib/fmt.git'
'git+https://github.com/brofield/simpleini.git')
-noextract=()
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -31,31 +25,53 @@ md5sums=('SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
git submodule init
for submodule in \
thirdparty/libADLMIDI thirdparty/libOPNMIDI \
thirdparty/JUCE thirdparty/fmt thirdparty/simpleini
do
- git config "submodule.$submodule.url" "$srcdir/`basename "$submodule"`"
+ git config "submodule.${submodule}.url" "${srcdir}/`basename "${submodule}"`"
done
git submodule update
+
+ cd "${srcdir}"
+ cp -rf "${_pkgname}" "${_pkgname}-opn"
}
build() {
- cd "$srcdir/$_pkgname"
- mkdir build
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DADLplug_CHIP=OPL3 ..
+ make
+
+ cd "${srcdir}/${_pkgname}-opn"
+ mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DADLplug_CHIP=OPL3 ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DADLplug_CHIP=OPN2 ..
make
}
-package() {
- cd "$srcdir/$_pkgname/build"
- make DESTDIR="$pkgdir/" install
+package_adlplug-git() {
+ pkgdesc="FM synthesizer for ADLMIDI with OPL3 chip emulation"
+ provides=('adlplug')
+ conflicts=('adlplug')
+
+ cd "${srcdir}/${_pkgname}/build"
+ make DESTDIR="${pkgdir}/" install
+}
+
+package_opnplug-git() {
+ pkgdesc="FM synthesizer for OPNMIDI with OPN2 chip emulation"
+ provides=('opnplug')
+ conflicts=('opnplug')
+
+ cd "${srcdir}/${_pkgname}-opn/build"
+ make DESTDIR="${pkgdir}/" install
}