summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2020-12-13 11:10:50 -0500
committerMario Finelli2020-12-13 11:10:50 -0500
commit249d9614f8d1d84c101b480922ae24d69a945f9b (patch)
treec408d4a23e72809df47c7582e7a97c38390e29dc
parent340a776052ff23fd3c4444c58126edd99288d59b (diff)
downloadaur-249d9614f8d1d84c101b480922ae24d69a945f9b.tar.gz
Clean up
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--adminer.install6
-rw-r--r--httpd-adminer.conf10
4 files changed, 38 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db4454fe1152..4ae5ea671896 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = adminer
- pkgdesc = A full-featured MySQL management tool written in PHP.
+ pkgdesc = A full-featured MySQL management tool written in PHP
pkgver = 4.7.8
- pkgrel = 1
+ pkgrel = 2
url = https://www.adminer.org
install = adminer.install
arch = any
license = Apache
- license = GPL
+ license = GPL2
depends = php
- optdepends = mysql
optdepends = apache
+ optdepends = elasticsearch
+ optdepends = mariadb
+ optdepends = mongodb
+ optdepends = mysql
optdepends = postgresql
optdepends = sqlite
source = adminer.install
source = httpd-adminer.conf
source = https://github.com/vrana/adminer/releases/download/v4.7.8/adminer-4.7.8.php
- sha256sums = a9b786e220c0deabcb96849ffa511f1ef0b130836f978a8504e1ffbc9c723e51
- sha256sums = 176b392620e8d972188685e0e202cba853a2ff5e3d0c90fef130ef1c8c2491c2
+ sha256sums = e8d00ae49761c4d9cbbb9d3e32756f601e28c74a306d55974accc753b2a5ed36
+ sha256sums = 7886a90cc6e57c48d18048344c1040f3ab6e361dfa7793b17b83604fdfd87f6e
sha256sums = eadca9f2194702a4c0bc74ad02846bf88fdf521128c205ac0ec2c345489b1384
pkgname = adminer
diff --git a/PKGBUILD b/PKGBUILD
index b6b524e2b6b9..4a1e05926a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,31 @@
pkgname=adminer
pkgver=4.7.8
-pkgrel=1
-pkgdesc="A full-featured MySQL management tool written in PHP."
-arch=('any')
-license=('Apache' 'GPL')
-depends=('php')
-optdepends=('mysql' 'apache' 'postgresql' 'sqlite')
+pkgrel=2
+pkgdesc="A full-featured MySQL management tool written in PHP"
+arch=(any)
+license=(Apache GPL2)
+depends=(php)
+optdepends=(apache elasticsearch mariadb mongodb mysql postgresql sqlite)
url="https://www.adminer.org"
-install=${pkgname}.install
-source=("${pkgname}.install"
+install=adminer.install
+source=("adminer.install"
"httpd-${pkgname}.conf"
"https://github.com/vrana/adminer/releases/download/v${pkgver}/adminer-${pkgver}.php")
-sha256sums=('a9b786e220c0deabcb96849ffa511f1ef0b130836f978a8504e1ffbc9c723e51'
- '176b392620e8d972188685e0e202cba853a2ff5e3d0c90fef130ef1c8c2491c2'
+sha256sums=('e8d00ae49761c4d9cbbb9d3e32756f601e28c74a306d55974accc753b2a5ed36'
+ '7886a90cc6e57c48d18048344c1040f3ab6e361dfa7793b17b83604fdfd87f6e'
'eadca9f2194702a4c0bc74ad02846bf88fdf521128c205ac0ec2c345489b1384')
package() {
- cd "$srcdir"
- install -Dm0644 "${pkgname}-${pkgver}.php" \
- "$pkgdir/usr/share/webapps/$pkgname/index.php"
+ cd "$srcdir"
+ install -Dm0644 "${pkgname}-${pkgver}.php" \
+ "$pkgdir/usr/share/webapps/$pkgname/index.php"
- # TODO: I don't really like this. What if someone is using nginx, for
- # example? Or doesn't care to have any configuration installed at all.
- # Consider removing.
- install -Dm0644 "httpd-${pkgname}.conf" \
- "$pkgdir/etc/httpd/conf/extra/httpd-${pkgname}.conf"
+ # TODO: I don't really like this. What if someone is using nginx, for
+ # example? Or doesn't care to have any configuration installed at all.
+ # Consider removing.
+ install -Dm0644 "httpd-${pkgname}.conf" \
+ "$pkgdir/etc/httpd/conf/extra/httpd-${pkgname}.conf"
}
+
+# vim: set ts=2 sw=2 et:
diff --git a/adminer.install b/adminer.install
index 893f68f56ff2..3e712df7fd88 100644
--- a/adminer.install
+++ b/adminer.install
@@ -9,9 +9,11 @@ http://localhost/adminer.
EOM
post_install() {
- echo -e "$MESSAGE";
+ echo -e "$MESSAGE";
}
post_upgrade() {
- echo -e "$MESSAGE";
+ echo -e "$MESSAGE";
}
+
+# vim: set ts=2 sw=2 et:
diff --git a/httpd-adminer.conf b/httpd-adminer.conf
index 34a66e40ce36..7dc81192789e 100644
--- a/httpd-adminer.conf
+++ b/httpd-adminer.conf
@@ -1,8 +1,8 @@
-# vim: ft=apache
-
Alias /adminer "/usr/share/webapps/adminer"
<Directory "/usr/share/webapps/adminer">
- AllowOverride All
- Options FollowSymlinks
- Require all granted
+ AllowOverride All
+ Options FollowSymlinks
+ Require all granted
</Directory>
+
+# vim: set ft=apache ts=2 sw=2 et: