summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:54:05 +0000
committerOtto Sabart2015-06-30 09:54:05 +0000
commitc85570da2d140a89ed1134eecc5facf533841beb (patch)
tree78724cfc7ee15ade3a462f039ec9e312d888be37
downloadaur-c85570da2d140a89ed1134eecc5facf533841beb.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
-rw-r--r--adminer.install17
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4af4c956fdc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = adminer-git
+ pkgdesc = Adminer (formerly phpMinAdmin) is a full-featured MySQL management tool written in PHP. GIT version.
+ pkgver = v4.1.0.r0.g6aed2f5
+ pkgrel = 1
+ url = http://www.adminer.org
+ install = adminer.install
+ arch = any
+ license = Apache License, Version 2.0
+ makedepends = git
+ depends = php
+ optdepends = mariadb
+ optdepends = apache
+ optdepends = adminer-skins: various CSS skins for adminer
+ optdepends = postgresql
+ optdepends = sqlite: for sqlite3
+ optdepends = sqlite2
+ provides = adminer
+ conflicts = adminer
+ source = adminer-git::git://adminer.git.sourceforge.net/gitroot/adminer/adminer
+ md5sums = SKIP
+
+pkgname = adminer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3503bb0f1db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot].com
+# Contributor: Uzsolt
+
+pkgname=adminer-git
+_gitname=adminer
+
+pkgver=v4.1.0.r0.g6aed2f5
+pkgrel=1
+pkgdesc="Adminer (formerly phpMinAdmin) is a full-featured MySQL management tool written in PHP. GIT version."
+url="http://www.adminer.org"
+arch=('any')
+license=('Apache License, Version 2.0')
+install=
+depends=('php')
+optdepends=('mariadb' 'apache' 'adminer-skins: various CSS skins for adminer' 'postgresql' 'sqlite: for sqlite3' 'sqlite2')
+conflicts=("adminer")
+provides=('adminer')
+makedepends=('git')
+install=adminer.install
+source=("$pkgname"::'git://adminer.git.sourceforge.net/gitroot/adminer/adminer')
+
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ _instdir=$pkgdir/usr/share/webapps/$_gitname
+ mkdir -p ${_instdir} $pkgdir/etc/webapps/$_gitname $pkgdir/etc/httpd/conf/extra
+
+ cp -R $srcdir/$pkgname/$_gitname/* $_instdir
+
+ # It's similar to phpMyAdmin
+ cat >$pkgdir/etc/webapps/$_gitname/apache.example.conf <<EOF
+ Alias /${_gitname} "/usr/share/webapps/${_gitname}"
+ <Directory "/usr/share/webapps/${_gitname}">
+ AllowOverride All
+ Options FollowSymlinks
+ Require all granted
+ php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:/usr/share/pear/"
+ </Directory>
+EOF
+ cp $pkgdir/etc/webapps/$_gitname/apache.example.conf $pkgdir/etc/httpd/conf/extra/httpd-${_gitname}.conf
+# echo "Include conf/extra/httpd-${pkgname}.conf" >> $pkgdir/etc/httpd/conf/httpd.conf
+}
diff --git a/adminer.install b/adminer.install
new file mode 100644
index 000000000000..4e4ac3de7b2f
--- /dev/null
+++ b/adminer.install
@@ -0,0 +1,17 @@
+TEXT='
+If you want to access adminer interface by your apache server, run following command as root:\n
+echo "Include conf/extra/httpd-adminer.conf" >> /etc/httpd/conf/httpd.conf\n\n
+
+And restart your apache running "rc.d restart httpd"\n
+Or (if you are using systemd) "systemctl restart httpd"\n\n
+
+After you can browse adminer on http://localhost/adminer\n';
+
+
+post_install() {
+ echo -e $TEXT;
+}
+
+post_upgrade() {
+ echo -e $TEXT;
+}