summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpider.007 / Sjon2015-06-09 10:52:38 +0200
committerLukas Fleischer2015-06-19 14:17:27 +0200
commit838387a3c6c1650dbc4bc7a115fe0c5e319be7b8 (patch)
treecbceaad370d45c4f1948fcd32c3752ee669b585b
downloadaur-838387a3c6c1650dbc4bc7a115fe0c5e319be7b8.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--adobe-air21
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a0f217dc84e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Thu Mar 5 17:39:41 UTC 2015
+pkgbase = adobe-air
+ pkgdesc = Crossplatform desktop applications build using proven web technologies
+ pkgver = 2.6
+ pkgrel = 1
+ url = http://labs.adobe.com/technologies/air/
+ arch = any
+ license = GPL
+ depends = adobe-air-sdk
+ depends = unzip
+ source = adobe-air
+ sha1sums = 87d2c0dcc288355200b431d4b8b595b690b8d075
+
+pkgname = adobe-air
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7b54ac90f14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Spider.007 <archPackage@spider007.net>
+
+pkgname=adobe-air
+pkgver=2.6
+pkgrel=1
+license=('GPL')
+arch=('any')
+pkgdesc="Crossplatform desktop applications build using proven web technologies"
+url="http://labs.adobe.com/technologies/air/"
+source=('adobe-air')
+depends=('adobe-air-sdk' 'unzip')
+
+package() {
+ install -Dm755 "$srcdir/adobe-air" "$pkgdir/usr/bin/adobe-air"
+}
+
+sha1sums=('87d2c0dcc288355200b431d4b8b595b690b8d075')
diff --git a/adobe-air b/adobe-air
new file mode 100644
index 000000000000..1ee49892a555
--- /dev/null
+++ b/adobe-air
@@ -0,0 +1,21 @@
+#!/bin/bash
+# Simple Adobe Air SDK wrapper script to use it as a simple AIR application launcher
+# By Spider.007 / Sjon
+
+if [[ -z "$1" ]]
+then
+ echo "Please supply an .air application as first argument"
+ exit 1
+fi
+
+tmpdir=`mktemp -d /tmp/adobeair.XXXXXXXXXX`
+
+echo "adobe-air: Extracting application to directory: $tmpdir"
+mkdir -p $tmpdir
+unzip -q $1 -d $tmpdir || exit 1
+
+echo "adobe-air: Attempting to start application"
+/opt/adobe-air-sdk/bin/adl -nodebug $tmpdir/META-INF/AIR/application.xml $tmpdir
+
+echo "adobe-air: Cleaning up temporary directory"
+rm -Rf $tmpdir && echo "adobe-air: Done"