summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-13 00:30:10 -0400
committerKevin MacMartin2015-06-13 00:30:10 -0400
commita2fc154d81e400e4c0c76ee692deb36586b43ae8 (patch)
tree1a4ba140946a0c7af9058cf35283eb5444d0ff18
parentde7ca198404a216723a3a9ee04aa717ff5e2bc88 (diff)
downloadaur-a2fc154d81e400e4c0c76ee692deb36586b43ae8.tar.gz
Update revision to include the tweaks requested by grondinm and schard and some bash syntax improvements, and added a gitignore
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
2 files changed, 36 insertions, 28 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b571fbe95948
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+AdobeAIRSDK.tbz2
diff --git a/PKGBUILD b/PKGBUILD
index bd79a69b32a4..8e462707d2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,49 @@
-# Maintainer: Prurigro
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
pkgname=adobe-air-sdk
pkgver=2.6
-pkgrel=9
-pkgdesc="Adobe Air Software Development Kit and Runtime Environment"
+pkgrel=10
+pkgdesc='Adobe Air Software Development Kit and Runtime Environment'
arch=('i686' 'x86_64')
-url="http://get.adobe.com/air/"
+url='http://get.adobe.com/air'
license=('custom')
options=('!strip' 'staticlibs')
depends=('gcc-libs' 'libxml2' 'nss' 'gtk2' 'libxslt')
depends_x86_64+=('lib32-gcc-libs' 'lib32-libxml2' 'lib32-nss' 'lib32-gtk2' 'lib32-libxslt')
install=$pkgname.install
-_air_root="/opt"
-
-source=('http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRSDK.tbz2')
+source=("http://airdownload.adobe.com/air/lin/download/$pkgver/AdobeAIRSDK.tbz2")
sha512sums=('8185db9749f05bd60f3e52bf12de779c9f22da73142aca41326f57e24ef9b62c8f4bd9b7ba28cd110c7c4288d61870a8a9b8806bd51ae5cfd860aa57745d4527')
noextract=('AdobeAIRSDK.tbz2')
+_air_root='/opt'
prepare() {
- install -d $pkgname
- tar jxf AdobeAIRSDK.tbz2 -C $pkgname
+ install -d $pkgname
+ tar jxf AdobeAIRSDK.tbz2 -C $pkgname
}
package() {
- # Install profile script
- install -dm755 "$pkgdir"/etc/profile.d
- echo -e "export AIR_HOME=$_air_root/$pkgname\n"'export PATH="$PATH:$AIR_HOME/bin"' > "$pkgdir"/etc/profile.d/$pkgname.sh
- echo -e "setenv AIR_HOME $_air_root/$pkgname\n"'setenv PATH "$PATH:$AIR_HOME/bin"' > "$pkgdir"/etc/profile.d/$pkgname.csh
- chmod 755 "$pkgdir"/etc/profile.d/$pkgname.{sh,csh}
-
- # Install directories
- install -dm755 "${pkgdir}${_air_root}" "$pkgdir"/usr/share/licenses/$pkgname "$pkgdir"/usr/share/doc/$pkgname/
-
- # Install main folder
- cp -r --no-preserve=ownership $pkgname "${pkgdir}${_air_root}"
-
- # Create a link to the license in the licenses folder
- ln -s "$_air_root"/$pkgname/"AIR SDK license.pdf" "$pkgdir"/usr/share/licenses/$pkgname/
-
- # Create links to the readme, samples and templates in the docs folder
- ln -s "$_air_root"/$pkgname"/AIR SDK Readme.txt" "$pkgdir"/usr/share/doc/$pkgname/
- ln -s "$_air_root"/$pkgname/samples "$pkgdir"/usr/share/doc/$pkgname/
- ln -s "$_air_root"/$pkgname/templates "$pkgdir"/usr/share/doc/$pkgname/
+ # Install profile script
+ install -dm755 "$pkgdir/etc/profile.d"
+ printf '%s\n%s\n' "export AIR_HOME=$_air_root/$pkgname" 'export PATH="$PATH:$AIR_HOME/bin"' \
+ > "$pkgdir/etc/profile.d/$pkgname.sh"
+ printf '%s\n%s\n' "setenv AIR_HOME $_air_root/$pkgname" 'setenv PATH "$PATH:$AIR_HOME/bin"' \
+ > "$pkgdir/etc/profile.d/$pkgname.csh"
+ chmod 755 "$pkgdir/etc/profile.d/$pkgname."{sh,csh}
+
+ # Install directories
+ install -dm755 "$pkgdir$_air_root" "$pkgdir/usr/share/licenses/$pkgname" "$pkgdir/usr/share/doc/$pkgname"
+
+ # Install main folder
+ cp -r --no-preserve=ownership $pkgname "$pkgdir$_air_root"
+
+ # Explicitly set permissions of the binaries
+ chmod 755 "$pkgdir$_air_root/$pkgname/bin/ad"{l,t}
+
+ # Create a link to the license in the licenses folder
+ ln -s "$_air_root/$pkgname/AIR SDK license.pdf" "$pkgdir/usr/share/licenses/$pkgname"
+
+ # Create links to the readme, samples and templates in the docs folder
+ ln -s "$_air_root/$pkgname/AIR SDK Readme.txt" "$pkgdir/usr/share/doc/$pkgname"
+ ln -s "$_air_root/$pkgname/samples" "$pkgdir/usr/share/doc/$pkgname"
+ ln -s "$_air_root/$pkgname/templates" "$pkgdir/usr/share/doc/$pkgname"
}