summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:46 -0400
committerKevin MacMartin2015-06-10 00:37:46 -0400
commitde7ca198404a216723a3a9ee04aa717ff5e2bc88 (patch)
tree54cce35d26035f78dd1323327a330eb71e28bd6b
downloadaur-de7ca198404a216723a3a9ee04aa717ff5e2bc88.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
-rw-r--r--adobe-air-sdk.install12
-rwxr-xr-xadobe-air-sdk.sh1
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f81b4f04104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = adobe-air-sdk
+ pkgdesc = Adobe Air Software Development Kit and Runtime Environment
+ pkgver = 2.6
+ pkgrel = 9
+ url = http://get.adobe.com/air/
+ install = adobe-air-sdk.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = libxml2
+ depends = nss
+ depends = gtk2
+ depends = libxslt
+ noextract = AdobeAIRSDK.tbz2
+ options = !strip
+ options = staticlibs
+ source = http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRSDK.tbz2
+ sha512sums = 8185db9749f05bd60f3e52bf12de779c9f22da73142aca41326f57e24ef9b62c8f4bd9b7ba28cd110c7c4288d61870a8a9b8806bd51ae5cfd860aa57745d4527
+ depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-libxml2
+ depends_x86_64 = lib32-nss
+ depends_x86_64 = lib32-gtk2
+ depends_x86_64 = lib32-libxslt
+
+pkgname = adobe-air-sdk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd79a69b32a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Prurigro
+
+pkgname=adobe-air-sdk
+pkgver=2.6
+pkgrel=9
+pkgdesc="Adobe Air Software Development Kit and Runtime Environment"
+arch=('i686' 'x86_64')
+url="http://get.adobe.com/air/"
+license=('custom')
+options=('!strip' 'staticlibs')
+depends=('gcc-libs' 'libxml2' 'nss' 'gtk2' 'libxslt')
+depends_x86_64+=('lib32-gcc-libs' 'lib32-libxml2' 'lib32-nss' 'lib32-gtk2' 'lib32-libxslt')
+install=$pkgname.install
+_air_root="/opt"
+
+source=('http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRSDK.tbz2')
+sha512sums=('8185db9749f05bd60f3e52bf12de779c9f22da73142aca41326f57e24ef9b62c8f4bd9b7ba28cd110c7c4288d61870a8a9b8806bd51ae5cfd860aa57745d4527')
+noextract=('AdobeAIRSDK.tbz2')
+
+prepare() {
+ install -d $pkgname
+ tar jxf AdobeAIRSDK.tbz2 -C $pkgname
+}
+
+package() {
+ # Install profile script
+ install -dm755 "$pkgdir"/etc/profile.d
+ echo -e "export AIR_HOME=$_air_root/$pkgname\n"'export PATH="$PATH:$AIR_HOME/bin"' > "$pkgdir"/etc/profile.d/$pkgname.sh
+ echo -e "setenv AIR_HOME $_air_root/$pkgname\n"'setenv PATH "$PATH:$AIR_HOME/bin"' > "$pkgdir"/etc/profile.d/$pkgname.csh
+ chmod 755 "$pkgdir"/etc/profile.d/$pkgname.{sh,csh}
+
+ # Install directories
+ install -dm755 "${pkgdir}${_air_root}" "$pkgdir"/usr/share/licenses/$pkgname "$pkgdir"/usr/share/doc/$pkgname/
+
+ # Install main folder
+ cp -r --no-preserve=ownership $pkgname "${pkgdir}${_air_root}"
+
+ # Create a link to the license in the licenses folder
+ ln -s "$_air_root"/$pkgname/"AIR SDK license.pdf" "$pkgdir"/usr/share/licenses/$pkgname/
+
+ # Create links to the readme, samples and templates in the docs folder
+ ln -s "$_air_root"/$pkgname"/AIR SDK Readme.txt" "$pkgdir"/usr/share/doc/$pkgname/
+ ln -s "$_air_root"/$pkgname/samples "$pkgdir"/usr/share/doc/$pkgname/
+ ln -s "$_air_root"/$pkgname/templates "$pkgdir"/usr/share/doc/$pkgname/
+}
diff --git a/adobe-air-sdk.install b/adobe-air-sdk.install
new file mode 100644
index 000000000000..0d60cf67be49
--- /dev/null
+++ b/adobe-air-sdk.install
@@ -0,0 +1,12 @@
+post_install() {
+/usr/bin/cat << EOF
+
+Adobe AIR SDK requires you to re-login to your profile before using
+
+To run an Adobe Air application, extract the archive into a folder and run:
+
+ adl -nodebug app-folder/META-INF/AIR/application.xml app-folder
+
+EOF
+}
+
diff --git a/adobe-air-sdk.sh b/adobe-air-sdk.sh
new file mode 100755
index 000000000000..c94d0e96d298
--- /dev/null
+++ b/adobe-air-sdk.sh
@@ -0,0 +1 @@
+export AIR_HOME=/opt/adobe-air-sdk