summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredchenjs2019-07-14 01:44:34 +0800
committerredchenjs2019-07-14 01:44:34 +0800
commitf735e937c9158a0b1ac49b25b9cf1caf27252da8 (patch)
tree786b5d74720a3f102fea4216e247c79ef91dc341
downloadaur-f735e937c9158a0b1ac49b25b9cf1caf27252da8.tar.gz
init commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e4f1f27b987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = adobe-source-han-mono-classic-fonts
+ pkgdesc = Adobe Source Han Mono - Classic Style Chinese Character
+ pkgver = 1.002
+ pkgrel = 4
+ url = https://github.com/adobe-fonts/source-han-mono
+ arch = any
+ license = OFL
+ source = git+https://github.com/redchenjs/source-han-mono-classic.git
+ md5sums = SKIP
+
+pkgname = adobe-source-han-mono-classic-fonts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a7b8f64b98ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c50bdbd01812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jack Chen <redchenjs@live.com>
+
+pkgname=adobe-source-han-mono-classic-fonts
+pkgver=1.002
+pkgrel=4
+pkgdesc="Adobe Source Han Mono - Classic Style Chinese Character"
+arch=('any')
+url="https://github.com/adobe-fonts/source-han-mono"
+license=('OFL')
+source=(
+ 'git+https://github.com/redchenjs/source-han-mono-classic.git'
+)
+md5sums=(
+ 'SKIP'
+)
+
+package() {
+ mkdir -p "${pkgdir}"/usr/
+ mkdir -p "${pkgdir}"/usr/share/
+ mkdir -p "${pkgdir}"/usr/share/fonts/
+ mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-sans/
+
+ cp -a "${srcdir}"/source-han-mono-classic/*.otf \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-sans/
+}