summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorval-amart2015-08-13 00:41:05 +0200
committerNarrat2015-08-13 00:41:05 +0200
commit2116290e1e6888fa45e1ba24c7a99ec59160864b (patch)
treefd71b9352856462821217313b4c5c9880a5d6cd4
parent2c4ea23d8c67029bec98e7aa79deaf3beff2e5d5 (diff)
downloadaur-2116290e1e6888fa45e1ba24c7a99ec59160864b.tar.gz
adom-noteye: Change binary and License install path
Since this stuff is in /opt this would remove the conflicts Created by: val-amart Added by: Narrat
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rwxr-xr-xadom-noteye.sh (renamed from adom.sh)0
3 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8d5c1a45721..73de5ac2b431 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = adom-noteye
pkgdesc = roguelike game with a quest-centric, plot driven structure
pkgver = 1.2.0_pre59
- pkgrel = 1
+ pkgrel = 2
url = http://www.adom.de/
arch = i686
arch = x86_64
@@ -18,11 +18,8 @@ pkgbase = adom-noteye
depends = sdl2_net
depends = sdl2_ttf
depends = zlib
- provides = adom
- conflicts = adom
- conflicts = adom-restricted
source = LICENSE
- source = adom.sh
+ source = adom-noteye.sh
sha1sums = 51d28fe3f0420cd354113fd7ceb2a1a7abf1b069
sha1sums = c99d3f55f59b2ee51e327b6d9e58fefd1e051ff2
source_i686 = http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_32_r59_pub.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index e5c80e5ff1ef..8e5cc7983966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Eugene Yunak <val-amart at mail dot ru>
# Contributor: Perttu Luukko <"perttu.luukko" followed by "@iki.fi">
pkgname=adom-noteye
pkgver=1.2.0_pre59
-pkgrel=1
+pkgrel=2
pkgdesc="roguelike game with a quest-centric, plot driven structure"
arch=('i686' 'x86_64')
-conflicts=('adom' 'adom-restricted')
-provides=('adom')
depends=('ncurses' 'mesa' 'lua51' 'libtinfo' 'libcaca' 'libmad' 'fluidsynth'
'sdl2_image' 'sdl2_mixer' 'sdl2_net' 'sdl2_ttf' 'zlib') # 'libpng12' (adom sdl2 link against it)
url="http://www.adom.de/"
license=('custom: "adom"')
source=(LICENSE
- adom.sh)
+ adom-noteye.sh)
source_i686+=(http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_32_r59_pub.tar.gz)
source_x86_64+=(http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_64_r59_pub.tar.gz)
sha1sums=('51d28fe3f0420cd354113fd7ceb2a1a7abf1b069'
@@ -24,7 +23,7 @@ sha1sums_x86_64=('3caf871e9ce1a3e33d240829de626ec670e0bd3a')
prepare() {
cd "adom/lib/"
-
+
# Remove some bundled libs for which we have perfectly good versions available
rm -f "libFLAC.so.8"
rm -f "libjpeg.so.8"
@@ -51,6 +50,6 @@ package() {
# Since the adom binary uses a relative RPATH, it's either
# this or patching the binary
- install -Dm755 "${srcdir}/adom.sh" "${pkgdir}/usr/bin/adom"
- install -m644 -D ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/adom/LICENSE
+ install -Dm755 "${srcdir}/adom-noteye.sh" "${pkgdir}/usr/bin/adom-noteye"
+ install -m644 -D ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/adom-noteye/LICENSE
}
diff --git a/adom.sh b/adom-noteye.sh
index d906148893a9..d906148893a9 100755
--- a/adom.sh
+++ b/adom-noteye.sh