summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-08-06 00:29:26 +0200
committerNarrat2015-08-06 00:29:26 +0200
commit2c4ea23d8c67029bec98e7aa79deaf3beff2e5d5 (patch)
treef1fa4c9e5efad82d1b0a3d6d332543f69a594266
parentf288b7f0985e43db996c688fde7bbbad61c8cb00 (diff)
downloadaur-2c4ea23d8c67029bec98e7aa79deaf3beff2e5d5.tar.gz
adom-noteye: Update to r59
Switch as much to repo packages as possible. All the SDL2 packages can be replaced by AUR/libpng12 (don't forget to comment the specific rm commands)
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD76
-rwxr-xr-xadom.sh3
4 files changed, 70 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a4c979124da..e8d5c1a45721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = adom-noteye
- pkgdesc = A roguelike game with a quest-centric, plot driven structure
- pkgver = 1.2.0_pre23
+ pkgdesc = roguelike game with a quest-centric, plot driven structure
+ pkgver = 1.2.0_pre59
pkgrel = 1
url = http://www.adom.de/
arch = i686
@@ -12,14 +12,23 @@ pkgbase = adom-noteye
depends = libtinfo
depends = libcaca
depends = libmad
- depends = libpng12
+ depends = fluidsynth
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_net
+ depends = sdl2_ttf
+ depends = zlib
provides = adom
conflicts = adom
conflicts = adom-restricted
- source = http://ancardia.us.to/download/adom_noteye_linux_ubuntu_32_1.2.0_pre23.tar.gz
source = LICENSE
- sha1sums = 409e70770cd914c88c28560a817e0ed14b65a265
+ source = adom.sh
sha1sums = 51d28fe3f0420cd354113fd7ceb2a1a7abf1b069
+ sha1sums = c99d3f55f59b2ee51e327b6d9e58fefd1e051ff2
+ source_i686 = http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_32_r59_pub.tar.gz
+ sha1sums_i686 = ce3bb56bafa0e90b08d209c37543710f6cde9244
+ source_x86_64 = http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_64_r59_pub.tar.gz
+ sha1sums_x86_64 = 3caf871e9ce1a3e33d240829de626ec670e0bd3a
pkgname = adom-noteye
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f5a385a0261b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.asc
+*.bz2
+*.gz
+*.log
+*.part
+*.pkg
+pkg/
+*.scm
+*.sig
+*.sign
+src/
+*.txt
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 1d7fc32c40be..e5c80e5ff1ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,56 @@
-# Maintainer: Perttu Luukko <"perttu.luukko" followed by "@iki.fi">
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Perttu Luukko <"perttu.luukko" followed by "@iki.fi">
pkgname=adom-noteye
-pkgver=1.2.0_pre23
+pkgver=1.2.0_pre59
pkgrel=1
-pkgdesc="A roguelike game with a quest-centric, plot driven structure"
+pkgdesc="roguelike game with a quest-centric, plot driven structure"
arch=('i686' 'x86_64')
conflicts=('adom' 'adom-restricted')
provides=('adom')
-depends=('ncurses' 'mesa' 'lua51' 'libtinfo' 'libcaca' 'libmad' 'libpng12')
+depends=('ncurses' 'mesa' 'lua51' 'libtinfo' 'libcaca' 'libmad' 'fluidsynth'
+ 'sdl2_image' 'sdl2_mixer' 'sdl2_net' 'sdl2_ttf' 'zlib') # 'libpng12' (adom sdl2 link against it)
url="http://www.adom.de/"
license=('custom: "adom"')
-sha1sums=('' '51d28fe3f0420cd354113fd7ceb2a1a7abf1b069')
-if [ "$CARCH" = x86_64 ]
- then
- _arch_link=64
- sha1sums[0]='746dd07f1f39ff663f136daaa60a073c6feedf3e'
- else
- _arch_link=32
- sha1sums[0]='409e70770cd914c88c28560a817e0ed14b65a265'
-fi
+source=(LICENSE
+ adom.sh)
+source_i686+=(http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_32_r59_pub.tar.gz)
+source_x86_64+=(http://media1.gamefront.com/moddb/2015/07/20/adom_noteye_linux_ubuntu_64_r59_pub.tar.gz)
+sha1sums=('51d28fe3f0420cd354113fd7ceb2a1a7abf1b069'
+ 'c99d3f55f59b2ee51e327b6d9e58fefd1e051ff2')
+sha1sums_i686=('ce3bb56bafa0e90b08d209c37543710f6cde9244')
+sha1sums_x86_64=('3caf871e9ce1a3e33d240829de626ec670e0bd3a')
-source=(http://ancardia.us.to/download/adom_noteye_linux_ubuntu_${_arch_link}_${pkgver}.tar.gz LICENSE)
+
+prepare() {
+ cd "adom/lib/"
+
+ # Remove some bundled libs for which we have perfectly good versions available
+ rm -f "libFLAC.so.8"
+ rm -f "libjpeg.so.8"
+ rm -f "liblua5.1.so.0"
+ ln -s ../../../usr/lib/liblua5.1.so liblua5.1.so.0
+ #rm -f "libmikmod.so.2"
+ # libnoteye.so we keep at this point
+ rm -f "libogg.so.0"
+ rm -f "libSDL2-2.0.so.0"
+ rm -f "libSDL2_image-2.0.so.0"
+ rm -f "libSDL2_mixer-2.0.so.0"
+ rm -f "libSDL2_net-2.0.so.0"
+ rm -f "libSDL2_ttf-2.0.so.0"
+ #rm -f "libtiff.so.4"
+ rm -f "libvorbisfile.so.3"
+ rm -f "libvorbis.so.0"
+ rm -f "libz.so.1"
+}
package() {
- install -m644 -D ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/adom/LICENSE
# Copy entire contents of the archive to /opt
install -d "${pkgdir}/opt"
cp -R "${srcdir}/adom" "${pkgdir}/opt/"
- # Remove some bundled libs for which we have perfectly good versions available
- cd "${pkgdir}/opt/adom/lib"
- rm -f "${pkgdir}/opt/adom/lib/libFLAC.so.8"
- rm -f "${pkgdir}/opt/adom/lib/libjpeg.so.8"
- rm -f "${pkgdir}/opt/adom/lib/liblua5.1.so.0"
- ln -s ../../../usr/lib/liblua5.1.so liblua5.1.so.0
- #rm -f "${pkgdir}/opt/adom/lib/libmikmod.so.2"
- # libnoteye.so we keep at this point
- rm -f "${pkgdir}/opt/adom/lib/libogg.so.0"
- #rm -f "${pkgdir}/opt/adom/lib/libSDL-1.2.so.0"
- #rm -f "${pkgdir}/opt/adom/lib/libSDL_image-1.2.so.0"
- #rm -f "${pkgdir}/opt/adom/lib/libSDL_mixer-1.2.so.0"
- #rm -f "${pkgdir}/opt/adom/lib/libSDL_net-1.2.so.0"
- #rm -f "${pkgdir}/opt/adom/lib/libtiff.so.4"
- rm -f "${pkgdir}/opt/adom/lib/libvorbisfile.so.3"
- rm -f "${pkgdir}/opt/adom/lib/libvorbis.so.0"
+
# Since the adom binary uses a relative RPATH, it's either
# this or patching the binary
- install -d "${pkgdir}/usr/bin"
- cat <<EOF > "${pkgdir}/usr/bin/adom"
-#!/bin/sh
-cd /opt/adom && ./adom
-EOF
- chmod 755 "${pkgdir}/usr/bin/adom"
+ install -Dm755 "${srcdir}/adom.sh" "${pkgdir}/usr/bin/adom"
+ install -m644 -D ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/adom/LICENSE
}
diff --git a/adom.sh b/adom.sh
new file mode 100755
index 000000000000..d906148893a9
--- /dev/null
+++ b/adom.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd /opt/adom && ./adom