summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-30 15:25:39 +0100
committerJaroslav Lichtblau2014-11-30 15:25:39 +0100
commit82388b8d3d811024d4acfff4e8d314d7050b9db3 (patch)
tree89847a3c3da5833d245bb31d22ddd0212081429e
parentee557cc828ce2907624140afdfc4dae703bdb49c (diff)
downloadaur-82388b8d3d811024d4acfff4e8d314d7050b9db3.tar.gz
adonthell-0.3.5-7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
-rw-r--r--configure.diff2
3 files changed, 31 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 166eef673a44..13a459161ac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = adonthell
pkgdesc = A 2D graphical, single player role playing game engine
pkgver = 0.3.5
- pkgrel = 6
- url = http://adonthell.linuxgames.com/
+ pkgrel = 7
+ url = http://adonthell.nongnu.org/
arch = i686
arch = x86_64
license = GPL
- depends = sdl_mixer>=1.2
- depends = sdl_ttf>=2
- depends = python>=2
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = python2
source = http://savannah.nongnu.org/download/adonthell/adonthell-src-0.3.5.tar.gz
source = configure.diff
md5sums = 64a344b1ed8a7808d7adafa337120a00
- md5sums = 196c9fd4240b3c2633dce3c864aa70fe
+ md5sums = 73bba2c5e67c8f4badeb2d2b0bdf4d8b
pkgname = adonthell
diff --git a/PKGBUILD b/PKGBUILD
index 6b10eeeef6dd..fb46a93e5d33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,39 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Gerardo Marset <gammer1994@gmail.com>
# Contributor: Christoph Zeiler <rabyte*gmail>
pkgname=adonthell
pkgver=0.3.5
-pkgrel=6
+pkgrel=7
pkgdesc="A 2D graphical, single player role playing game engine"
arch=('i686' 'x86_64')
-url="http://adonthell.linuxgames.com/"
+url="http://adonthell.nongnu.org/"
license=('GPL')
-depends=('sdl_mixer>=1.2' 'sdl_ttf>=2' 'python>=2')
-source=(http://savannah.nongnu.org/download/$pkgname/$pkgname-src-$pkgver.tar.gz \
- configure.diff)
+depends=('sdl_mixer' 'sdl_ttf' 'python2')
+source=(http://savannah.nongnu.org/download/$pkgname/$pkgname-src-$pkgver.tar.gz
+ configure.diff)
md5sums=('64a344b1ed8a7808d7adafa337120a00'
- '196c9fd4240b3c2633dce3c864aa70fe')
+ '73bba2c5e67c8f4badeb2d2b0bdf4d8b')
-build() {
+prepare() {
cd $pkgname-$pkgver
- patch -Np0 -i ../configure.diff || return 1
-
- # NEW NEW NEW ;-) Set default screen-mode to fullscreen!!
+ patch -Np0 -i ../configure.diff
+# NEW NEW NEW ;-) Set default screen-mode to fullscreen!!
sed 's|screen_mode = 0|screen_mode = 1|g' -i src/prefs.cc
+ sed '/^ *for ac_prog in / s|python|python2|' -i configure
+}
+
+build() {
+ cd $pkgname-$pkgver
+
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$pkgdir install
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
}
diff --git a/configure.diff b/configure.diff
index befefa94c972..311b0b082e57 100644
--- a/configure.diff
+++ b/configure.diff
@@ -5,7 +5,7 @@
-CFLAGS="-g -Wall -fno-exceptions"
-+CFLAGS+=" -fno-exceptions"
++CFLAGS+=" -fno-exceptions -fpermissive"
CPPFLAGS=""
DEFS=""