summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerry2019-06-18 17:39:22 +0800
committerJerry2019-06-18 17:39:22 +0800
commit53536e02b77cf2e6f68361fd7e749d575926b841 (patch)
treec92d36d26202d777906103c1e40b75e6274df5b1
downloadaur-53536e02b77cf2e6f68361fd7e749d575926b841.tar.gz
adplay-git 1.8.2.gccd1b88
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..737356805343
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = adplay-git
+ pkgdesc = AdPlug's UNIX console-based frontend
+ pkgver = 1.8.2.gccd1b88
+ pkgrel = 1
+ url = https://github.com/adplug/adplay-unix
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = adplug-git
+ provides = adplay
+ conflicts = adplay
+ source = adplay-unix::git+https://github.com/adplug/adplay-unix.git#branch=master
+ md5sums = SKIP
+
+pkgname = adplay-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..040a4f0e5c2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# AdPlug's UNIX console-based frontend
+# Maintainer: Jerry Xiao <isjerryxiao at outlook dot com>
+
+_srcname=adplay-unix
+pkgname=adplay-git
+pkgver=1.8.2.gccd1b88
+pkgrel=1
+pkgdesc="AdPlug's UNIX console-based frontend"
+arch=('i686' 'x86_64')
+url="https://github.com/adplug/adplay-unix"
+license=('GPL')
+depends=('adplug-git')
+provides=('adplay')
+conflicts=('adplay')
+source=(
+ "${_srcname}::git+https://github.com/adplug/adplay-unix.git#branch=master"
+)
+md5sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "$srcdir/${_srcname}"
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${_srcname}"
+ autoreconf --install
+}
+
+build() {
+ cd "$srcdir/${_srcname}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${_srcname}"
+ make DESTDIR="$pkgdir" install
+}