summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-05 01:43:18 +0000
committerDaniel Bermond2018-08-05 01:43:18 +0000
commitcd20015d58688d45dfe76bf1372558dbf79d92b2 (patch)
tree29391caf84f87ec17a07aaba66bfe8314d588f0f
parent1d387d26cc99e5dbf076c3a18cf6ab0733f34a83 (diff)
downloadaur-cd20015d58688d45dfe76bf1372558dbf79d92b2.tar.gz
Update dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 810aa9856393..2176b80aaebc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = adriconf
pkgdesc = Advanded DRI Configurator for the Mesa drivers
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jlHertel/adriconf/
arch = i686
arch = x86_64
@@ -10,11 +10,16 @@ pkgbase = adriconf
makedepends = boost
makedepends = gettext
makedepends = gtest
- depends = mesa
+ depends = gcc-libs
depends = gtkmm3
+ depends = glibmm
+ depends = glib2
+ depends = libsigc++
depends = boost-libs
depends = libxml++
depends = libx11
+ depends = libglvnd
+ depends = mesa
depends = libdrm
depends = pciutils
conflicts = adriconf-git
diff --git a/PKGBUILD b/PKGBUILD
index 3962ef8864af..4ea8a283c3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=adriconf
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Advanded DRI Configurator for the Mesa drivers'
arch=('i686' 'x86_64')
url='https://github.com/jlHertel/adriconf/'
license=('GPL3')
-depends=('mesa' 'gtkmm3' 'boost-libs' 'libxml++' 'libx11' 'libdrm' 'pciutils')
+depends=('gcc-libs' 'gtkmm3' 'glibmm' 'glib2' 'libsigc++' 'boost-libs'
+ 'libxml++' 'libx11' 'libglvnd' 'mesa' 'libdrm' 'pciutils')
makedepends=('cmake' 'boost' 'gettext' 'gtest')
conflicts=('adriconf-git')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/jlHertel/adriconf/archive/v${pkgver}.tar.gz"
@@ -38,9 +39,8 @@ package() {
make DESTDIR="$pkgdir" install
- install -D -m755 adriconf "${pkgdir}/usr/bin/adriconf"
-
- install -D -m644 "${srcdir}/adriconf.desktop" "${pkgdir}/usr/share/applications/adriconf.desktop"
-
- install -D -m644 "${srcdir}/adriconf.png" "${pkgdir}/usr/share/pixmaps/adriconf.png"
+ install -D -m755 adriconf -t "${pkgdir}/usr/bin"
+
+ install -D -m644 "${srcdir}/adriconf.desktop" -t "${pkgdir}/usr/share/applications"
+ install -D -m644 "${srcdir}/adriconf.png" -t "${pkgdir}/usr/share/pixmaps"
}