summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Tang2020-11-13 23:55:47 +0800
committerWilliam Tang2020-11-13 23:55:47 +0800
commit5ad1c6e1c3b8066991b031119051c91fe50c9cba (patch)
tree08690e5ce2f7c1671a38d8e08d8271401ada1918
downloadaur-5ad1c6e1c3b8066991b031119051c91fe50c9cba.tar.gz
Initial Commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD30
-rw-r--r--adsklicensing.install3
-rw-r--r--adsklicensing.service12
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49f3e4a0b0ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = adsklicensing
+ pkgdesc = Autodesk Licensing Checking Software
+ pkgver = 9.2.1.2399
+ pkgrel = 1
+ url = https://www.autodesk.com/
+ install = adsklicensing.install
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = libglvnd
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = pcre
+ options = !strip
+ source = manual://adsklicensing9.2.1.2399-0-0.x86_64.rpm
+ source = adsklicensing.service
+ sha256sums = d9404416708ce2ad5c1f88dbd2bb26fa799440a6b15217be7f85028b0d23c476
+ sha256sums = e5612c0dd6297dd959d93369e899fa3fc85a08a2e42358c81b970a3a7d85ce7d
+
+pkgname = adsklicensing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ef0c0099186
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: William Tang <galaxyking0419@gmail.com>
+
+pkgname=adsklicensing
+pkgver=9.2.1.2399
+pkgrel=1
+pkgdesc='Autodesk Licensing Checking Software'
+arch=('x86_64')
+url="https://www.autodesk.com/"
+license=('custom')
+depends=('gcc-libs' 'glib2' 'glibc' 'libglvnd' 'libx11' 'libxau' 'libxcb' 'libxdmcp' 'pcre')
+
+DLAGENTS+=('manual::/usr/bin/echo \ \ Note: Please download the package manually from the official website')
+source=('manual://adsklicensing9.2.1.2399-0-0.x86_64.rpm'
+ 'adsklicensing.service')
+sha256sums=('d9404416708ce2ad5c1f88dbd2bb26fa799440a6b15217be7f85028b0d23c476'
+ 'e5612c0dd6297dd959d93369e899fa3fc85a08a2e42358c81b970a3a7d85ce7d')
+
+options=(!strip)
+install='adsklicensing.install'
+
+package() {
+ cp -a $srcdir/opt $pkgdir/
+
+ # Remove Service Files
+ rm $pkgdir/opt/Autodesk/AdskLicensing/9.2.1.2399/AdskLicensingService/adsklicensing*
+
+ # Install Custom Service File
+ install -D -m 644 adsklicensing.service $pkgdir/usr/lib/systemd/system/adsklicensing.service
+}
+
diff --git a/adsklicensing.install b/adsklicensing.install
new file mode 100644
index 000000000000..3b45acc12f80
--- /dev/null
+++ b/adsklicensing.install
@@ -0,0 +1,3 @@
+pre_remove() {
+ rm -rf /var/opt/Autodesk/AdskLicensingService
+}
diff --git a/adsklicensing.service b/adsklicensing.service
new file mode 100644
index 000000000000..880b3a2b51a8
--- /dev/null
+++ b/adsklicensing.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Autodesk Licensing Service
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/opt/Autodesk/AdskLicensing/9.2.1.2399/AdskLicensingService/AdskLicensingService --run
+Restart=always
+RestartSec=0
+
+[Install]
+WantedBy=multi-user.target