summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShaumyadeep Chaudhuri2017-12-06 16:31:03 +0530
committerShaumyadeep Chaudhuri2017-12-06 16:31:03 +0530
commit0f030d0b062862d0354da49ff4cf76ade4bf67f7 (patch)
tree2e4fa510cdd8392e5736266d21b600f0f57935b8
downloadaur-0f030d0b062862d0354da49ff4cf76ade4bf67f7.tar.gz
Advanced Rest Client - Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--advanced-rest-client.install14
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2458e81eed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = advanced-rest-client
+ pkgdesc = A developert tool to test a HTTP request. The Advanced REST Client desktop application.
+ pkgver = 11.0.31
+ pkgrel = 1
+ url = https://advancedrestclient.com/
+ install = advanced-rest-client.install
+ arch = x86_64
+ license = custom
+ depends = gconf
+ depends = libnotify
+ depends = libappindicator-gtk3
+ depends = libxtst
+ depends = nss
+ depends = libxss
+ options = !strip
+ source_x86_64 = https://github.com/advanced-rest-client/arc-electron/releases/download/v11.0.31/arc-11.0.31-amd64.deb
+ sha256sums_x86_64 = ca13ec4c8446dc608cd9e33cbceb8b04f59dcfbd09cb7c373fe74deb99cefcc2
+
+pkgname = advanced-rest-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b260d459cdfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Shaumyadeep Chaudhuri <shaumya at gmail.com>
+
+pkgname=advanced-rest-client
+pkgver=11.0.31
+pkgrel=1
+pkgdesc='A developert tool to test a HTTP request. The Advanced REST Client desktop application.'
+arch=('x86_64')
+url='https://advancedrestclient.com/'
+license=('custom')
+options=('!strip')
+depends=(
+ 'gconf'
+ 'libnotify'
+ 'libappindicator-gtk3'
+ 'libxtst'
+ 'nss'
+ 'libxss')
+install=advanced-rest-client.install
+source_x86_64=("https://github.com/advanced-rest-client/arc-electron/releases/download/v${pkgver}/arc-${pkgver}-amd64.deb")
+sha256sums_x86_64=('ca13ec4c8446dc608cd9e33cbceb8b04f59dcfbd09cb7c373fe74deb99cefcc2')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ # Install
+ cp -dr --no-preserve=ownership {opt,usr} "${pkgdir}"/
+}
+
diff --git a/advanced-rest-client.install b/advanced-rest-client.install
new file mode 100644
index 000000000000..c1aa3b7b4511
--- /dev/null
+++ b/advanced-rest-client.install
@@ -0,0 +1,14 @@
+post_install() {
+ # Link to the binary
+ ln -sf '/opt/Advanced REST Client/advanced-rest-client' '/usr/local/bin/advanced-rest-client'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ # Delete the link to the binary
+ rm -f '/usr/local/bin/advanced-rest-client'
+}
+