summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-03-22 21:10:42 +0100
committerBaptiste Jonglez2016-03-22 21:10:42 +0100
commit254fe8cc6b22b283018aa85749fe4df24f897050 (patch)
treed2fe5beb7d201b4fb08397866b1337719c81b7e2
downloadaur-254fe8cc6b22b283018aa85749fe4df24f897050.tar.gz
advanced-strategic-command: Initial upload
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD42
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b9a27b65e13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 20:10:42 UTC 2016
+pkgbase = advanced-strategic-command
+ pkgdesc = A free, turn-based strategy game, designed in the tradition of the Battle Isle series from Bluebyte
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = http://asc-hq.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = boost
+ makedepends = zip
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_sound
+ depends = libsigc++
+ depends = lua
+ depends = physfs
+ depends = boost-libs
+ depends = expat
+ depends = freetype2
+ depends = wxgtk
+ depends = xvidcore
+ depends = loki-lib
+ source = http://downloads.sourceforge.net/project/asc-hq/ASC%20Source/2.6.1/asc-2.6.1.0.tar.bz2
+ source = http://www.asc-hq.org/music/frontiers.ogg
+ source = http://www.asc-hq.org/music/time_to_strike.ogg
+ source = http://www.asc-hq.org/music/machine_wars.ogg
+ md5sums = b8668c378e730e982458d5c082e7e0ca
+ md5sums = c27415246734d59e27e6a786ee4820d2
+ md5sums = 0f4de5275ab649f4426d110840e3e1ea
+ md5sums = b4421ddd67a9e44d90a49a1d8bdf44c3
+
+pkgname = advanced-strategic-command
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ce64516f013
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+pkgname=advanced-strategic-command
+pkgver=2.6.1
+pkgrel=1
+pkgdesc="A free, turn-based strategy game, designed in the tradition of the Battle Isle series from Bluebyte"
+arch=('i686' 'x86_64')
+url="http://asc-hq.org/"
+license=('GPL2')
+depends=("sdl" "sdl_image" "sdl_mixer" "sdl_sound" "libsigc++"
+ "lua" "physfs" "boost-libs" "expat" "freetype2" "wxgtk"
+ "xvidcore"
+ "loki-lib")
+makedepends=("boost" "zip")
+source=("http://downloads.sourceforge.net/project/asc-hq/ASC%20Source/$pkgver/asc-${pkgver}.0.tar.bz2"
+ "http://www.asc-hq.org/music/frontiers.ogg"
+ "http://www.asc-hq.org/music/time_to_strike.ogg"
+ "http://www.asc-hq.org/music/machine_wars.ogg")
+md5sums=('b8668c378e730e982458d5c082e7e0ca'
+ 'c27415246734d59e27e6a786ee4820d2'
+ '0f4de5275ab649f4426d110840e3e1ea'
+ 'b4421ddd67a9e44d90a49a1d8bdf44c3')
+
+prepare() {
+ cd "$srcdir/asc-${pkgver}.0"
+ # Music files are provided separately by upstream.
+ cp "$srcdir"/*.ogg data/music/
+}
+
+build() {
+ cd "$srcdir/asc-${pkgver}.0"
+ ./configure --prefix=/usr
+ # Recent versions of ligsigc++ require C++11. Overring CXXFLAGS
+ # prevents the program from building, so we override CXX instead.
+ make CXX="g++ -std=c++11"
+}
+
+package() {
+ cd "$srcdir/asc-${pkgver}.0"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: