summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2017-03-02 09:54:33 +0100
committerSebastian Wolf2017-03-02 09:54:33 +0100
commit32d55e5c447479d9c6b8a20c463fb9bfd337d1cd (patch)
tree4cb093c88b590540ecc7a080329dc7f1c3911607
parent427a5269c4c34629192acd69a27f5d64eebee5a9 (diff)
downloadaur-32d55e5c447479d9c6b8a20c463fb9bfd337d1cd.tar.gz
Update to 3.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--advancemame.desktop9
3 files changed, 57 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 625dc56475b4..2e27df50befb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,30 @@
# Generated by mksrcinfo v8
-# Mon Dec 19 14:32:24 UTC 2016
+# Thu Mar 2 08:52:38 UTC 2017
pkgbase = advancemame
- pkgdesc = AdvanceMAME allows you to play Arcade games with video hardware like TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend.
- pkgver = 3.0
+ pkgdesc = Unofficial MAME/MESS version with an advanced video support for use with TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend.
+ pkgver = 3.3
pkgrel = 1
url = http://www.advancemame.it
arch = i686
arch = x86_64
arch = armv7h
license = GPL
- depends = sdl
+ makedepends = imagemagick
depends = alsa-lib
- depends = expat
depends = freetype2
depends = slang
+ provides = advancemenu
+ provides = advancemess
conflicts = advancemenu
- source = https://github.com/amadvance/advancemame/releases/download/v3.0/advancemame-3.0.tar.gz
- sha256sums = 19077f55ab636ac8e996d87775a1eb86c2ced381cbcd57c1e0c0bf410f4b4101
+ conflicts = advancemess
+ source = https://github.com/amadvance/advancemame/releases/download/v3.3/advancemame-3.3.tar.gz
+ source = http://www.advancemame.it/favicon.ico
+ source = advancemame.desktop
+ sha256sums = 707f7fc51e10d01fcd73f1d82f54a444244ee0c95d82a1f3d8ac9e4b8315a4aa
+ sha256sums = 42c33684c5c6e44269c7102dc404652721e4802bb19a495c264127bfee52a9d0
+ sha256sums = 6633a06a972f69142af5c3ee538b80e0705ef79eed9f5f4097811015be1cfb41
+ depends_i686 = sdl2
+ depends_x86_64 = sdl2
pkgname = advancemame
diff --git a/PKGBUILD b/PKGBUILD
index 3aef7bdf183c..0817938ec7cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,52 @@
# Contributor: Sebastian Wolf <fatmike303@gmail.com>
pkgname=advancemame
-pkgver=3.0
+pkgver=3.3
pkgrel=1
-pkgdesc="AdvanceMAME allows you to play Arcade games with video hardware like TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend."
+pkgdesc="Unofficial MAME/MESS version with an advanced video support for use with TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend."
arch=('i686' 'x86_64' 'armv7h')
url="http://www.advancemame.it"
-depends=('sdl' 'alsa-lib' 'expat' 'freetype2' 'slang')
-conflicts=('advancemenu')
+depends=('alsa-lib' 'freetype2' 'slang')
+depends_i686=('sdl2')
+depends_x86_64=('sdl2')
+makedepends=('imagemagick')
+conflicts=('advancemenu' 'advancemess')
+provides=('advancemenu' 'advancemess')
license=('GPL')
-source=("https://github.com/amadvance/advancemame/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('19077f55ab636ac8e996d87775a1eb86c2ced381cbcd57c1e0c0bf410f4b4101')
+source=(
+ "https://github.com/amadvance/advancemame/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "http://www.advancemame.it/favicon.ico"
+ "${pkgname}.desktop"
+)
+sha256sums=(
+ '707f7fc51e10d01fcd73f1d82f54a444244ee0c95d82a1f3d8ac9e4b8315a4aa'
+ '42c33684c5c6e44269c7102dc404652721e4802bb19a495c264127bfee52a9d0'
+ '6633a06a972f69142af5c3ee538b80e0705ef79eed9f5f4097811015be1cfb41'
+)
build() {
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr || return 1
+ cd ${srcdir}/${pkgname}-${pkgver}
+ if [ "$CARCH" == 'armv7h' ]; then # Do not link SDL into Raspberry Pi build
+ ./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char" --prefix=/usr --disable-sdl --disable-sdl2
+ else
+ ./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char" --prefix=/usr
+ fi
make || return 1
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # Install built files
make bindir="${pkgdir}/usr/bin/" \
datadir="${pkgdir}/usr/share/" \
mandir="${pkgdir}/usr/share/man/" \
pkgdocdir="${pkgdir}/usr/share/doc/${pkgname}/" \
install
+
+ # Install menu entry
+ cd ..
+ convert favicon.ico ${pkgname}.png
+ install -Dm644 ${pkgname}.png "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 ${pkgname}.desktop "$pkgdir/usr/share/applications/${pkgname}.desktop"
}
diff --git a/advancemame.desktop b/advancemame.desktop
new file mode 100644
index 000000000000..785edcb292f7
--- /dev/null
+++ b/advancemame.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=AdvanceMAME
+Comment=Play Arcade games
+Exec=advmenu
+Terminal=false
+Type=Application
+Icon=advancemame
+Categories=Game;
+StartupNotify=false