summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2021-02-24 21:34:20 +0100
committerSebastian Wolf2021-02-24 21:34:20 +0100
commit6f810a5c99401e6710a0f845f807403cb2ab7441 (patch)
treec2df4e9209bc99eeeb7d4cae2154408e1ec4c40d
parent86fdc98765d860636f239d1df9ce0a7e392da11b (diff)
downloadaur-6f810a5c99401e6710a0f845f807403cb2ab7441.tar.gz
Fix build errors due new gcc 10 default for -fno-common
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95439dbe9ef7..71823234f88e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Sep 13 09:21:20 UTC 2018
pkgbase = advancemame
pkgdesc = Unofficial MAME/MESS version with an advanced video support for use with TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend.
pkgver = 3.9
- pkgrel = 1
+ pkgrel = 2
url = http://www.advancemame.it
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c09785d31463..0e1275d10bc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Sebastian Wolf <fatmike303@gmail.com>
pkgname=advancemame
pkgver=3.9
-pkgrel=1
+pkgrel=2
pkgdesc="Unofficial MAME/MESS version with an advanced video support for use with TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend."
arch=('i686' 'x86_64' 'armv7h')
url="http://www.advancemame.it"
@@ -25,6 +25,10 @@ sha256sums=(
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ # Fix build errors due new gcc 10 default for -fno-common
+ for line in 290 855 856; do
+ sed -i -e "${line}s/^/extern /" src/drivers/cavepgm.c
+ done
if [ "$CARCH" == 'armv7h' ]; then # Do not link SDL into Raspberry Pi build
./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char -fno-stack-protector" --prefix=/usr --disable-sdl --disable-sdl2
else