summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2018-03-03 21:02:50 +0100
committerSebastian Wolf2018-03-03 21:02:50 +0100
commitd688248e24fd5d68caa8fa67a9edb96957719868 (patch)
treef3b5445220086eed62bc497ae6726595f02c6ecf
parent6dcf49c778d123ab0337fcaaf67d02ceaa1733ec (diff)
downloadaur-d688248e24fd5d68caa8fa67a9edb96957719868.tar.gz
Disable stack smashing detection
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8a8bae00cad..1c61300eecf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Mar 3 19:40:10 UTC 2018
+# Sat Mar 3 20:02:10 UTC 2018
pkgbase = advancemame
pkgdesc = Unofficial MAME/MESS version with an advanced video support for use with TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend.
pkgver = 3.7
- pkgrel = 1
+ pkgrel = 2
url = http://www.advancemame.it
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a8269124f2ee..1289e12c8531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Sebastian Wolf <fatmike303@gmail.com>
pkgname=advancemame
pkgver=3.7
-pkgrel=1
+pkgrel=2
pkgdesc="Unofficial MAME/MESS version with an advanced video support for use with TVs, Arcade monitors, PC monitors and LCD screens. Also includes AdvanceMENU frontend."
arch=('i686' 'x86_64' 'armv7h')
url="http://www.advancemame.it"
@@ -26,9 +26,9 @@ sha256sums=(
build() {
cd ${srcdir}/${pkgname}-${pkgver}
if [ "$CARCH" == 'armv7h' ]; then # Do not link SDL into Raspberry Pi build
- ./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char" --prefix=/usr --disable-sdl --disable-sdl2
+ ./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char -fno-stack-protector" --prefix=/usr --disable-sdl --disable-sdl2
else
- ./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char" --prefix=/usr
+ ./configure CFLAGS="-O2 -fno-strict-aliasing -fno-strict-overflow -fsigned-char -fno-stack-protector" --prefix=/usr
fi
make || return 1
}