summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVresod2020-10-23 14:05:57 -0400
committerVresod2020-10-23 14:06:43 -0400
commit170631bb91b4133cc24f49cb27c56557b58fed40 (patch)
tree803ae7ceb13dc447512859a47f5692f98c233d51
parent55f6943589ef83223ed7eef8e9fd6813eece6a06 (diff)
downloadaur-170631bb91b4133cc24f49cb27c56557b58fed40.tar.gz
use $pkgver
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc882c0f9a28..1dcf85c74ea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="Advanced Copy is a mod for the GNU cp and GNU mv tools which adds a pro
arch=( "any" )
url="https://github.com/jarun/advcpmv"
license=("GPL3")
-source=( "http://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz" "https://raw.githubusercontent.com/jarun/advcpmv/master/advcpmv-0.8-8.32.patch" "mv.1.gz" "cp.1.gz" )
+source=( "http://ftp.gnu.org/gnu/coreutils/coreutils-$pkgver.tar.xz" "https://raw.githubusercontent.com/jarun/advcpmv/master/advcpmv-0.8-$pkgver.patch" "mv.1.gz" "cp.1.gz" )
sha256sums=('4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa'
'd39b493ccbd3a8423bd00fc5767e385b0588efca53ec9699f8b328715aa47368'
'6ab6916b1ea86be2c669c8c99dbd2b08848f19cd719b68aaf27a9d460ca2dd83'
@@ -16,24 +16,24 @@ optdepends=( )
makedepends=( "xz" )
prepare() {
- tar xvJf "coreutils-8.32.tar.xz"
- cd coreutils-8.32
- mv ../advcpmv-0.8-8.32.patch .
- patch -p1 -i advcpmv-0.8-8.32.patch
+ tar xvJf "coreutils-$pkgver.tar.xz"
+ cd coreutils-$pkgver
+ mv ../advcpmv-0.8-$pkgver.patch .
+ patch -p1 -i advcpmv-0.8-$pkgver.patch
./configure
cd ..
}
build() {
- cd coreutils-8.32
+ cd coreutils-$pkgver
make
cd ..
}
package() {
- install -Dm755 "coreutils-8.32/src/cp" "$pkgdir"/usr/bin/advcp
- install -Dm755 "coreutils-8.32/src/mv" "$pkgdir"/usr/bin/advmv
+ install -Dm755 "coreutils-$pkgver/src/cp" "$pkgdir"/usr/bin/advcp
+ install -Dm755 "coreutils-$pkgver/src/mv" "$pkgdir"/usr/bin/advmv
install -Dm644 "mv.1.gz" "$pkgdir"/usr/share/man/man1/advmv.1.gz
install -Dm644 "cp.1.gz" "$pkgdir"/usr/share/man/man1/advcp.1.gz
}