summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVresod2020-10-23 13:22:17 -0400
committerVresod2020-10-23 13:22:17 -0400
commit317cf121294d1b157346de9e05ad31e5f9edab80 (patch)
treeeb1d778009ed95751d949e32250b0d3b25804984
downloadaur-317cf121294d1b157346de9e05ad31e5f9edab80.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e4cd9883259
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = advcpmv
+ pkgdesc = Advanced Copy is a mod for the GNU cp and GNU mv tools which adds a progress bar and provides some info on what's going on
+ pkgver = 8.32
+ pkgrel = 1
+ url = https://github.com/jarun/advcpmv
+ arch = any
+ license = GPL3
+ makedepends = xz
+ source = http://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz
+ source = https://raw.githubusercontent.com/jarun/advcpmv/master/advcpmv-0.8-8.32.patch
+ sha256sums = 4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
+ sha256sums = d39b493ccbd3a8423bd00fc5767e385b0588efca53ec9699f8b328715aa47368
+
+pkgname = advcpmv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1234f8a2d40d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Vresod <lukebinkofsky@gmail.com>
+pkgname=advcpmv
+pkgver=8.32
+pkgrel=1
+pkgdesc="Advanced Copy is a mod for the GNU cp and GNU mv tools which adds a progress bar and provides some info on what's going on"
+arch=( "any" )
+url="https://github.com/jarun/advcpmv"
+license=("GPL3")
+source=( "http://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz" "https://raw.githubusercontent.com/jarun/advcpmv/master/advcpmv-0.8-8.32.patch" )
+sha256sums=('4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa'
+ 'd39b493ccbd3a8423bd00fc5767e385b0588efca53ec9699f8b328715aa47368')
+depends=( )
+optdepends=( )
+makedepends=( "xz" )
+
+prepare() {
+ tar xvJf "coreutils-8.32.tar.xz"
+ cd coreutils-8.32
+ mv ../advcpmv-0.8-8.32.patch .
+ patch -p1 -i advcpmv-0.8-8.32.patch
+ ./configure
+ cd ..
+}
+
+build() {
+ cd coreutils-8.32
+ make
+ cd ..
+}
+
+package() {
+ install -Dm644 "coreutils/src/cp" "$pkgdir"/usr/bin/advcp
+ install -Dm644 "coreutils/src/mv" "$pkgdir"/usr/bin/advmv
+}