summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2024-04-20 22:02:12 +1000
committercorey drew bruce2024-04-20 22:02:12 +1000
commiteb3ab54c6c1633461abc96dd6e71b3a591f0d3c5 (patch)
treee1768cd4fefb6f5f8cb221f806f80d53fe68faf2
parente2f5a0be0aa1a9cd99b4205e474ae824beff95ba (diff)
downloadaur-eb3ab54c6c1633461abc96dd6e71b3a591f0d3c5.tar.gz
Adventures of Demo 1.0.2 - Updated repo link as I have moved it to a big main repository for all my projects - Added the checksums to the package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 983a5eae13a9..a620ee3c27a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = adventuresofdemo
pkgdesc = This is a small game based on the TheXTech engine with the A2XT content pack made by the Talkhaus community. It's a remix of old SMBX episodes such as The Invasion 1, brought to the A2XT universe!
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
- url = https://gitlab.com/thextech-archive/aod-script
+ url = https://gitlab.com/linuxbombay/thextech-archive/theadventuresofdemo
arch = pentium4
arch = i386
arch = i686
@@ -15,7 +15,7 @@ pkgbase = adventuresofdemo
depends = wget
depends = unzip
depends = yad
- source = https://gitlab.com/thextech-archive/aod-script/-/archive/1.0.1-1/aod-script-1.0.1-1.tar.bz2
- sha256sums = SKIP
+ source = https://gitlab.com/linuxbombay/thextech-archive/theadventuresofdemo/-/archive/1.0.2/theadventuresofdemo-1.0.2.tar.bz2
+ sha256sums = d2e9c8a1810c51905b3969082645456f97b12ffe1b0dada0518e06e70e2e0150
pkgname = adventuresofdemo
diff --git a/PKGBUILD b/PKGBUILD
index 0379d9a98c9c..60bfde11ddd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
pkgname=adventuresofdemo
_pkgname=AdventuresofDemo
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="This is a small game based on the TheXTech engine with the A2XT content pack made by the Talkhaus community. It's a remix of old SMBX episodes such as The Invasion 1, brought to the A2XT universe!"
arch=('pentium4' 'i386' 'i686' 'x86_64' 'aarch64')
-url="https://gitlab.com/thextech-archive/aod-script"
+url="https://gitlab.com/linuxbombay/thextech-archive/theadventuresofdemo"
license=('GPL')
depends=('thextech-bin' 'adventuresofdemo-assets' 'wget' 'unzip' 'yad')
makedepends=('unzip')
-source=("https://gitlab.com/thextech-archive/aod-script/-/archive/$pkgver-$pkgrel/aod-script-$pkgver-$pkgrel.tar.bz2")
-sha256sums=("SKIP")
+source=("$url/-/archive/$pkgver/theadventuresofdemo-$pkgver.tar.bz2")
+sha256sums=('d2e9c8a1810c51905b3969082645456f97b12ffe1b0dada0518e06e70e2e0150')
package() {
install -dm755 "$pkgdir/usr/bin"
@@ -20,10 +20,10 @@ package() {
for dir in aod-*/ ; do mv "${dir}" "$_pkgname" ;done
cp -r "$srcdir/$_pkgname/$pkgname.png" "$pkgdir/usr/share/pixmaps"
cp -r "$srcdir/$_pkgname/." "$pkgdir/usr/share/games/$_pkgname"
- mv "$srcdir/$_pkgname/aod" "$pkgdir/usr/bin"
+ install -Dm755 "$srcdir/$_pkgname/$pkgname" "$pkgdir/usr/bin"
# Desktop Entry
- install -Dm644 "$srcdir/$_pkgname/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
- sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 "$srcdir/$_pkgname/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$pkgname.desktop"
}