summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMurat Çileli2019-05-08 08:13:28 +0300
committerMurat Çileli2019-05-08 08:13:28 +0300
commit001bbaef57f02d356e7d37255fd1c90a158e6d54 (patch)
treeb061f61fa3224c89b99958bfa9a3bc5b27a28498
parenta49a934f138053689d7db08df3e35e2ba42172a9 (diff)
downloadaur-001bbaef57f02d356e7d37255fd1c90a158e6d54.tar.gz
Update 2019-05-08 08:13
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 451e784861b5..9a7178329b2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = adwaita-creamy-gtk-theme
pkgdesc = Refreshed new Adwaita theme with creamy colors and minor changes.
pkgver = 3.24.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/murat-cileli/adwaita-creamy
- arch = x86_64
+ arch = any
license = MIT
- provides = adwaita-creamy-gtk-theme
source = https://github.com/murat-cileli/adwaita-creamy/archive/3.24.8.tar.gz
- sha256sums = SKIP
+ sha256sums = 1a90d1c117b4b2c5e1d877288ace89dd269caef16038c611fa50fa245f7c1279
pkgname = adwaita-creamy-gtk-theme
diff --git a/PKGBUILD b/PKGBUILD
index cc7097534d74..bc74449ce5ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Murat Çileli <murat.cileli@gmail.com>
+# Contributor: Svitozar Cherepii <razotivs@gmail.com>
-pkgname="adwaita-creamy-gtk-theme"
-pkgver="3.24.8"
-pkgrel="1"
+_pkgname=adwaita-creamy
+pkgname=$_pkgname-gtk-theme
+pkgver=3.24.8
+pkgrel=2
pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes."
-arch=("x86_64")
-license=("MIT")
-url="https://github.com/murat-cileli/adwaita-creamy"
-makedepends=()
-provides=("adwaita-creamy-gtk-theme")
-source=("https://github.com/murat-cileli/adwaita-creamy/archive/$pkgver.tar.gz")
-sha256sums=("SKIP")
+url="https://github.com/murat-cileli/$_pkgname"
+arch=('any')
+license=('MIT')
+source=("https://github.com/murat-cileli/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('1a90d1c117b4b2c5e1d877288ace89dd269caef16038c611fa50fa245f7c1279')
-package() {
- # Create directory
- mkdir -p $pkgdir/usr/share/themes/adwaita-creamy
-
- # Copy contents
- cp -r "$srcdir/adwaita-creamy-3.24.8/." "$pkgdir/usr/share/themes/adwaita-creamy"
+package() {
+ cd $_pkgname-$pkgver
+ find gtk-2.0 gtk-3.0 index.theme -type f -exec \
+ install -Dm644 {} "$pkgdir/usr/share/themes/$_pkgname/{}" \;
}