summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2023-07-06 16:47:02 +0200
committerMattia Borda2023-07-06 16:47:02 +0200
commit5ef4c1da880222cce1a17d85e21349d02112ca3a (patch)
tree6eb14224bb339d891b0f1154b626613013713c53
parent7aab2ecc6af7afec70013a86b2c1b8d3a1dd9005 (diff)
downloadaur-5ef4c1da880222cce1a17d85e21349d02112ca3a.tar.gz
Update to new install method
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--adwaita-for-steam.install32
3 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e33f79751be..42d27f65bb40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = adwaita-for-steam
pkgdesc = A skin to make Steam look more like a native GNOME app
- pkgver = 1.1
+ pkgver = 1.3
pkgrel = 1
url = https://github.com/tkashkin/adwaita-for-steam
install = adwaita-for-steam.install
arch = any
license = MIT
makedepends = git
- depends = sssm
depends = cantarell-fonts
optdepends = steam: if you don't use the flatpak version of Steam
- source = git+https://github.com/tkashkin/adwaita-for-steam#tag=v1.1
- b2sums = SKIP
+ source = git+https://github.com/tkashkin/adwaita-for-steam#tag=v1.3
+ source = adwaita-for-steam.sh
+ md5sums = SKIP
+ md5sums = 515391d36e5e42a64c647f2caf294aec
pkgname = adwaita-for-steam
diff --git a/PKGBUILD b/PKGBUILD
index 8255fd2ca0a9..30cc7ce71ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
pkgname=adwaita-for-steam
-pkgver=1.1
+pkgver=1.3
pkgrel=1
pkgdesc='A skin to make Steam look more like a native GNOME app'
arch=(any)
url=https://github.com/tkashkin/$pkgname
license=(MIT)
-depends=(sssm cantarell-fonts)
+depends=(cantarell-fonts)
optdepends=("steam: if you don't use the flatpak version of Steam")
makedepends=(git)
-source=(git+$url#tag=v$pkgver)
-b2sums=('SKIP')
+source=(git+$url#tag=v$pkgver $pkgname.sh)
+md5sums=('SKIP'
+ '515391d36e5e42a64c647f2caf294aec')
install=adwaita-for-steam.install
package() {
+ install $pkgname.sh -Dm755 "$pkgdir/usr/bin/$pkgname"
cd $pkgname
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
- find Adwaita -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/steam/skins/{}" \;
+ find colorthemes fonts web install.py -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/$pkgname/{}" \;
}
diff --git a/adwaita-for-steam.install b/adwaita-for-steam.install
index e18e21bf879a..4d929eae98f7 100644
--- a/adwaita-for-steam.install
+++ b/adwaita-for-steam.install
@@ -1,27 +1,37 @@
post_install() {
- /usr/bin/sssm sync Adwaita
echo ""
- echo "****Adwaita for Steam was installed!****"
+ echo "****Adwaita for Steam files have been installed!****"
echo ""
- echo "If there were issues installing the skin, unlink the skins directory and reinstall the package"
- echo "rm -rf ~/.steam/steam/skins"
+ echo "Run the following command to complete the installation"
echo ""
- echo "Now, select the skin in Steam Settings -> Interface."
+ echo "adwaita-for-steam"
+ echo ""
+ echo "See https://github.com/tkashkin/Adwaita-for-Steam#arguments for possible arguments"
+ echo ""
+ echo "If you decide to uninstall the package, you'll have to run the following command in order to correctly complete the uninstall process"
+ echo ""
+ echo "adwaita-for-steam -u"
echo ""
}
post_upgrade() {
- /usr/bin/sssm sync Adwaita
echo ""
- echo "****Adwaita for Steam was installed!****"
+ echo "****Adwaita for Steam files have been updated!****"
+ echo ""
+ echo "Run the following command to complete the updating process"
echo ""
- echo "If there were issues installing the skin, unlink the skins directory and reinstall the package"
- echo "rm -rf ~/.steam/steam/skins"
+ echo "adwaita-for-steam"
echo ""
- echo "Now, select the skin in Steam Settings -> Interface."
+ echo "See https://github.com/tkashkin/Adwaita-for-Steam#arguments for possible arguments"
echo ""
}
post_remove() {
- /usr/bin/sssm remove Adwaita
+ echo ""
+ echo "****Adwaita for Steam files have been removed!****"
+ echo ""
+ echo "You should have run the following command before uninstalling the package. If you haven't, please reinstall adwaita-for-steam, run this command, and uninstall the pacakage."
+ echo ""
+ echo "adwaita-for-steam -u"
+ echo ""
}