summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2022-12-18 14:51:15 +0100
committerMattia Borda2022-12-18 14:51:15 +0100
commitc2c0886a56d64fa91a9563bee65da9240df2ea5e (patch)
treec8a229a200aeb4f9e672d9ca7baa045b6cf76779
downloadaur-c2c0886a56d64fa91a9563bee65da9240df2ea5e.tar.gz
Initial import: 0.22
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--adwaita-for-steam.install10
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..515c2e8ea278
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = adwaita-for-steam
+ pkgdesc = A skin to make Steam look more like a native GNOME app
+ pkgver = 0.22
+ pkgrel = 1
+ url = https://github.com/tkashkin/adwaita-for-steam
+ install = adwaita-for-steam.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = steam
+ source = git+https://github.com/tkashkin/adwaita-for-steam#tag=v0.22
+ b2sums = SKIP
+
+pkgname = adwaita-for-steam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12138ff8a7a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
+
+pkgname=adwaita-for-steam
+pkgver=0.22
+pkgrel=1
+pkgdesc='A skin to make Steam look more like a native GNOME app'
+arch=('any')
+url="https://github.com/tkashkin/$pkgname"
+license=('MIT')
+depends=('steam')
+makedepends=('git')
+source=("git+$url#tag=v$pkgver")
+b2sums=('SKIP')
+install=adwaita-for-steam.install
+
+package() {
+ cd $pkgname
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/${pkgname%-git}
+ find Adwaita -type f -exec install -Dm644 "{}" "$pkgdir/usr/lib/steam/skins/{}" \;
+}
diff --git a/adwaita-for-steam.install b/adwaita-for-steam.install
new file mode 100644
index 000000000000..3136b8d70377
--- /dev/null
+++ b/adwaita-for-steam.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo ""
+ echo "****Adwaita for Steam was installed!****"
+ echo ""
+ echo "You still have to make steam able to read the skin location in your system directory /usr/lib:"
+ echo "ln -s /usr/lib/steam/skins ~/.steam/steam/skins"
+ echo ""
+ echo "Now, select the skin in Steam Settings -> Interface."
+ echo ""
+}