summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2023-02-02 18:20:41 +0100
committerMattia Borda2023-02-02 18:20:41 +0100
commit86010d1cfd0f1492bd7b6a25f4fb5b7666e6375e (patch)
tree7ee844444559334a945416dbb541fa2c9dfb31d5
parentd10f287e51e5f3d8b7cfe2a05d51ec242ede7048 (diff)
downloadaur-86010d1cfd0f1492bd7b6a25f4fb5b7666e6375e.tar.gz
Use sssm to manage the skin
-rw-r--r--PKGBUILD18
-rw-r--r--adwaita-for-steam.install21
2 files changed, 28 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4af9d1322723..1caeb43e82a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
pkgname=adwaita-for-steam-git
-pkgver=0.21.r1.g4ad8301
+pkgver=0.29.r2.g9492a7c
pkgrel=1
pkgdesc='A skin to make Steam look more like a native GNOME app'
-arch=('any')
-url="https://github.com/tkashkin/${pkgname%-git}"
-license=('MIT')
-depends=('steam')
-makedepends=('git')
+arch=(any)
+url=https://github.com/tkashkin/${pkgname%-git}
+license=(MIT)
+depends=(steam sssm)
+makedepends=(git)
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
-source=("git+$url")
-b2sums=('SKIP')
+source=(git+$url)
+b2sums=(SKIP)
install=adwaita-for-steam.install
pkgver()
@@ -25,5 +25,5 @@ package()
{
cd ${pkgname%-git}
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/${pkgname%-git}
- find Adwaita -type f -exec install -Dm644 "{}" "$pkgdir/usr/lib/steam/skins/{}" \;
+ find Adwaita -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/steam/skins/{}" \;
}
diff --git a/adwaita-for-steam.install b/adwaita-for-steam.install
index 3136b8d70377..baa14c2129e7 100644
--- a/adwaita-for-steam.install
+++ b/adwaita-for-steam.install
@@ -1,10 +1,27 @@
post_install() {
+ /usr/bin/sssm sync Adwaita
echo ""
echo "****Adwaita for Steam was installed!****"
echo ""
- echo "You still have to make steam able to read the skin location in your system directory /usr/lib:"
- echo "ln -s /usr/lib/steam/skins ~/.steam/steam/skins"
+ echo "If there were some issues installing the skin, unlink the skins directory and reinstall the package"
+ echo "rm -rf ~/.steam/steam/skins"
echo ""
echo "Now, select the skin in Steam Settings -> Interface."
echo ""
}
+
+post_upgrade() {
+ /usr/bin/sssm sync Adwaita
+ echo ""
+ echo "****Adwaita for Steam was installed!****"
+ echo ""
+ echo "If there were some issues installing the skin, unlink the skins directory and reinstall the package"
+ echo "rm -rf ~/.steam/steam/skins"
+ echo ""
+ echo "Now, select the skin in Steam Settings -> Interface."
+ echo ""
+}
+
+post_remove() {
+ /usr/bin/sssm remove Adwaita
+}