summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadu Potop2022-04-07 10:46:31 +0100
committerRadu Potop2022-04-07 10:46:31 +0100
commit5e7a6fe9448ccc955874f3194c55cebc846988aa (patch)
treebf07c86b489d5989b7cacf0974715d8dfd332e1e
downloadaur-5e7a6fe9448ccc955874f3194c55cebc846988aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f18263935a13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = adwaita-icon-theme-41
+ pkgdesc = GNOME standard icons, version 41
+ pkgver = 41.0
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/adwaita-icon-theme
+ arch = any
+ license = LGPL3
+ license = CCPL:by-sa
+ makedepends = git
+ makedepends = gtk3
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = librsvg
+ provides = adwaita-icon-theme
+ source = git+https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git#commit=8670d0eb2414c1ac16d927da5d1a22142ba5e346
+ sha256sums = SKIP
+
+pkgname = adwaita-icon-theme-41
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d9e2fd9afab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Radu Potop <radu at wooptoo dot com>
+
+pkgname=adwaita-icon-theme-41
+basename=adwaita-icon-theme
+pkgver=41.0
+pkgrel=1
+pkgdesc="GNOME standard icons, version 41"
+url="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
+arch=(any)
+license=(LGPL3 CCPL:by-sa)
+depends=(hicolor-icon-theme gtk-update-icon-cache librsvg)
+makedepends=(git gtk3)
+provides=(adwaita-icon-theme)
+conflits=(adwaita-icon-theme)
+_commit=8670d0eb2414c1ac16d927da5d1a22142ba5e346 # tags/41.0^0
+source=("git+https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $basename
+ git describe --tags | sed 's/\.rc/rc/;s/-/+/g'
+}
+
+prepare() {
+ cd $basename
+ autoreconf -fvi
+}
+
+build() {
+ cd $basename
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd $basename
+ make check
+}
+
+package() {
+ cd $basename
+ make DESTDIR="$pkgdir" install
+}