summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-11-24 20:44:23 -0500
committeréclairevoyant2022-11-24 20:44:23 -0500
commita5ef7bfe05458d1474d2a3f16a84e9c7103e530b (patch)
tree0e49ebffecf0006b8e58207d24f4d397395befa9
parent07eea144fb6d7e0b75e293a108e91e6ab28006b8 (diff)
downloadaur-a5ef7bfe05458d1474d2a3f16a84e9c7103e530b.tar.gz
chore: add .gitignore, cleanup
Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c413d2ce61bc..85f1fc75314f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = adwaita-icon-theme-git
pkgdesc = GNOME standard icons
- pkgver = 42.0+r18+gefd1c615a
+ pkgver = 43+r60+g4f8e8dc69
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/adwaita-icon-theme
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index e03e410f8758..d696a2862b8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: éclairevoyant
+# Contributor: Philip Goto <philip dot goto at gmail.com>
-pkgname=adwaita-icon-theme-git
-pkgver=42.0+r18+gefd1c615a
+_pkgname=adwaita-icon-theme
+pkgname="$_pkgname-git"
+pkgver=43+r60+g4f8e8dc69
pkgrel=1
pkgdesc='GNOME standard icons'
-arch=(any)
-url='https://gitlab.gnome.org/GNOME/adwaita-icon-theme'
-license=(LGPL3 CCPL:by-sa)
-depends=(hicolor-icon-theme gtk-update-icon-cache librsvg)
-makedepends=(git gtk3)
-provides=(adwaita-icon-theme)
-conflicts=(adwaita-icon-theme)
-source=("git+${url}.git")
-b2sums=(SKIP)
+arch=('any')
+url="https://gitlab.gnome.org/GNOME/$_pkgname"
+license=('LGPL3' 'CCPL:by-sa')
+depends=('hicolor-icon-theme' 'gtk-update-icon-cache' 'librsvg')
+makedepends=('git' 'gtk3')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd adwaita-icon-theme
+ cd $_pkgname
git describe --long --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
- cd adwaita-icon-theme
+ cd $_pkgname
autoreconf -fvi
}
build() {
- cd adwaita-icon-theme
+ cd $_pkgname
./configure --prefix=/usr
make
}
check() {
- cd adwaita-icon-theme
- make check
+ make -C $_pkgname check
}
package() {
- cd adwaita-icon-theme
- make DESTDIR="$pkgdir" install
+ make -C $_pkgname DESTDIR="$pkgdir" install
}