summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Costa2020-01-19 05:13:39 -0300
committerGustavo Costa2020-01-19 05:13:39 -0300
commiteb55443898df5e2c90bb20f3148a93cda3d4cbe6 (patch)
tree5e4ac4e650379d53de19cfc93135692ab177e0c1
downloadaur-eb55443898df5e2c90bb20f3148a93cda3d4cbe6.tar.gz
Added official Adwaita++’s AUR
-rw-r--r--.SRCINFO16
-rwxr-xr-xCHANGELOG.sh26
-rw-r--r--PKGBUILD25
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11d0af113932
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = adwaita-plus-git
+ pkgdesc = A third-party icons theme, based on new GNOME Project's Adwaita
+ pkgver = 5.0
+ pkgrel = 1
+ url = https://github.com/Bonandry/adwaita-plus
+ changelog = CHANGELOG.sh
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = adwaita-plus
+ conflicts = adwaita-plus
+ source = git+https://github.com/Bonandry/adwaita-plus.git
+ sha256sums = SKIP
+
+pkgname = adwaita-plus-git
+
diff --git a/CHANGELOG.sh b/CHANGELOG.sh
new file mode 100755
index 000000000000..229d1b90f93b
--- /dev/null
+++ b/CHANGELOG.sh
@@ -0,0 +1,26 @@
+#!/bin/bash
+
+BRIGHTORANGE="\e[0;38;2;175;104;76m"
+BRIGHTPINK="\e[0;38;2;245;88;89m"
+BROWN="\e[0;38;2;175;104;76m"
+DARKRED="\e[0;38;2;124;22;34m"
+PINK="\e[0;38;2;213;38;57m"
+SHAMROCK="\e[0;38;2;46;194;126m"
+SKYBLUE="\e[0;38;2;37;178;238m"
+YELLOW="\e[0;38;2;254;209;75m"
+
+BOLD="\033[1m"
+
+NC='\033[0m' # No Color
+
+echo -e "${BRIGHTPINK}${BOLD}From the version 5.0, the Adwaita++ versions will be named after a tree or leaf randomly in Latin.${NC}"
+echo -e " "
+
+echo -e "${BRIGHTORANGE}#${NC} ${BRIGHTPINK}5.0${NC} – ${BROWN}${BOLD}Paubrasilia echinata${NC}"
+echo -e "${PINK}➡${NC} New Adwaita++ logotype, based on GNOME Project's original Adwaita icons theme logotype"
+echo -e "${PINK}➡${NC} ${SKYBLUE}@gusbemacbe${NC} has upgrade the new battery design that GNOME Project developers did not upgrade for a decade!"
+echo -e "${PINK}➡${NC} Increased from 2170 to 3009 apps icons!"
+echo -e "${PINK}➡${NC} ${SKYBLUE}@gusbemacbe${NC} has completed the full support for KDE and made more than 2 thousand beautiful Breeze icons in pure Adwaita++ style!"
+echo -e "${PINK}➡${NC} Added new 23 places icons."
+echo -e "${PINK}➡${NC} A new colour of places icons, inspired by the latest Yaru’s places icons."
+echo -e " " \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcdbc33a9044
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gustavo Costa <gusbemacbe@gmail.com>
+
+pkgname=adwaita-plus-git
+pkgver=5.0
+pkgrel=1
+pkgdesc="A third-party icons theme, based on new GNOME Project's Adwaita"
+arch=('any')
+url="https://github.com/Bonandry/${pkgname/-git/}"
+license=('GPL3')
+changelog=CHANGELOG.sh
+makedepends=('git')
+conflicts=(${pkgname/-git/})
+provides=(${pkgname/-git/})
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver()
+{
+ git -C ${pkgname/-git/} describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+package()
+{
+ make -C ${pkgname/-git/} DESTDIR="$pkgdir/" install
+}