summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Hardman2017-12-28 14:43:36 -0700
committerAlan Hardman2017-12-28 14:43:36 -0700
commit6412e444424baca42846a76f0e637d84a5147727 (patch)
treea759bdb2afcda3719a690f186307f6dc18537cf9
downloadaur-6412e444424baca42846a76f0e637d84a5147727.tar.gz
Adding initial PKGBUILD for Adwaita Xfce
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e12b853f83d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = adwaita-xfce-theme-git
+ pkgdesc = A Modified Adwaita GTK Theme, designed and optimized for Xfce.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/thearakattack/adwaita-xfce
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = xfwm4
+ optdepends = xfdesktop: The Xfce desktop
+ provides = adwaita-xfce-theme
+ conflicts = adwaita-xfce-theme
+ source = git+https://github.com/thearakattack/adwaita-xfce.git
+ sha256sums = SKIP
+
+pkgname = adwaita-xfce-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fe9bd493193
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alan Hardman <alan@phpizza.com>
+
+pkgname=adwaita-xfce-theme-git
+pkgver=1.0
+pkgrel=1
+pkgdesc='A Modified Adwaita GTK Theme, designed and optimized for Xfce.'
+arch=('any')
+url='https://github.com/thearakattack/adwaita-xfce'
+license=('GPL2')
+depends=('xfwm4')
+makedepends=('git')
+optdepends=('xfdesktop: The Xfce desktop')
+provides=('adwaita-xfce-theme')
+conflicts=('adwaita-xfce-theme')
+source=('git+https://github.com/thearakattack/adwaita-xfce.git')
+sha256sums=('SKIP')
+
+package() {
+ cd adwaita-xfce
+ install -dm755 $pkgdir/usr/share/themes
+ cp -R * $pkgdir/usr/share/themes/
+ rm $pkgdir/usr/share/themes/README.md
+}
+