summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-23 10:56:03 +0800
committerzxp198210052024-01-23 10:56:03 +0800
commitb8295ce226c7c5a60638e8be8b59ec720ff53ea7 (patch)
tree15b40da0aee04cd577ff18a42040c2ed0e900ff3
parent9ab7bcd624b40e3fcbdd1554ad1008fce95a889e (diff)
downloadaur-b8295ce226c7c5a60638e8be8b59ec720ff53ea7.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--aechoterm.sh6
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94aedb819463..df3131da759f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = aechoterm-bin
pkgdesc = A free, cross-platform terminal and file management tool for accessing remote servers with SSH and SFTP protocols.闪令是一款免费的、跨平台的,以SSH、SFTP协议访问远程服务器的终端、文件管理工具
pkgver = 4.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://ec.nantian.com.cn/
arch = aarch64
arch = x86_64
- license = custom
+ license = LicenseRef-custom
depends = electron13
depends = hicolor-icon-theme
depends = lib32-glibc
depends = java-runtime
depends = lib32-gcc-libs
depends = python
+ depends = nodejs
provides = aechoterm=4.0.1
conflicts = aechoterm
+ options = !strip
source = aechoterm.sh
- sha256sums = 68521cf799a902fb3c86aa1ebdcfa92566ee49621b0e1db5873a0501d893b2e6
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = aechoterm-4.0.1-aarch64.deb::https://ec.cnd.nantiangzzx.com/Aechoterm_4.0.1_arm64.deb
sha256sums_aarch64 = 5ad55272b26a667cfcca3cc8c31b0afdabae8c718694b645cb19c83dc7387838
source_x86_64 = aechoterm-4.0.1-x86_64.deb::https://ec.cnd.nantiangzzx.com/Aechoterm_4.0.1_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 3b7d3ba9688f..dfed643fed90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=aechoterm-bin
_pkgname=Aechoterm
pkgver=4.0.1
_electronversion=13
-pkgrel=2
+pkgrel=3
pkgdesc="A free, cross-platform terminal and file management tool for accessing remote servers with SSH and SFTP protocols.闪令是一款免费的、跨平台的,以SSH、SFTP协议访问远程服务器的终端、文件管理工具"
arch=(
'aarch64'
@@ -11,7 +11,7 @@ arch=(
)
url="https://ec.nantian.com.cn/"
_ghurl="https://github.com/Aechoterm/Aechoterm"
-license=('custom')
+license=('LicenseRef-custom')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -21,11 +21,13 @@ depends=(
'java-runtime'
'lib32-gcc-libs'
'python'
+ 'nodejs'
)
+options=('!strip')
source=("${pkgname%-bin}.sh")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::https://ec.cnd.nantiangzzx.com/${_pkgname}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::https://ec.cnd.nantiangzzx.com/${_pkgname}_${pkgver}_amd64.deb")
-sha256sums=('68521cf799a902fb3c86aa1ebdcfa92566ee49621b0e1db5873a0501d893b2e6')
+sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('5ad55272b26a667cfcca3cc8c31b0afdabae8c718694b645cb19c83dc7387838')
sha256sums_x86_64=('c3cd799babbfca9a6c367891ed8612279bb59dd78ff93a374c304e9f69d78d43')
build() {
@@ -34,7 +36,7 @@ build() {
-e "s|@appasar@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|/opt/${_pkgname}/${pkgname%-bin} --no-sandbox %U|${pkgname%-bin}|g;s|Development|Utility|g" \
+ sed "s|/opt/${_pkgname}/${pkgname%-bin} --no-sandbox|${pkgname%-bin}|g;s|Development|Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
diff --git a/aechoterm.sh b/aechoterm.sh
index 98f84b151b4f..aacd8f895847 100644
--- a/aechoterm.sh
+++ b/aechoterm.sh
@@ -6,10 +6,10 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file