summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-29 15:23:11 +0800
committerzxp198210052024-02-29 15:23:11 +0800
commite167bd89d418d00547a9c65b906e84440d7ba74b (patch)
tree114442558714cf7b3d56ccfd805e3581f64280e2
parentb8295ce226c7c5a60638e8be8b59ec720ff53ea7 (diff)
downloadaur-e167bd89d418d00547a9c65b906e84440d7ba74b.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--aechoterm.sh10
3 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df3131da759f..00d5f7c7bf36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = aechoterm-bin
pkgdesc = A free, cross-platform terminal and file management tool for accessing remote servers with SSH and SFTP protocols.闪令是一款免费的、跨平台的,以SSH、SFTP协议访问远程服务器的终端、文件管理工具
pkgver = 4.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://ec.nantian.com.cn/
arch = aarch64
arch = x86_64
license = LicenseRef-custom
depends = electron13
depends = hicolor-icon-theme
- depends = lib32-glibc
depends = java-runtime
- depends = lib32-gcc-libs
depends = python
depends = nodejs
provides = aechoterm=4.0.1
conflicts = aechoterm
options = !strip
+ source = LICENSE.html::https://ec.nantian.com.cn//privacy-agreement.html
source = aechoterm.sh
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = cc65895a835817a900c9c2c4006a1738a6f2284cfa29eeb8283fd0043121931e
+ sha256sums = f80acf84a87f3f50d7c4e2ed22f4d0e8b09dd98a6c26253f2524e5413771eab1
source_aarch64 = aechoterm-4.0.1-aarch64.deb::https://ec.cnd.nantiangzzx.com/Aechoterm_4.0.1_arm64.deb
sha256sums_aarch64 = 5ad55272b26a667cfcca3cc8c31b0afdabae8c718694b645cb19c83dc7387838
source_x86_64 = aechoterm-4.0.1-x86_64.deb::https://ec.cnd.nantiangzzx.com/Aechoterm_4.0.1_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index dfed643fed90..e4346d2c75a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=aechoterm-bin
_pkgname=Aechoterm
pkgver=4.0.1
_electronversion=13
-pkgrel=3
+pkgrel=4
pkgdesc="A free, cross-platform terminal and file management tool for accessing remote servers with SSH and SFTP protocols.闪令是一款免费的、跨平台的,以SSH、SFTP协议访问远程服务器的终端、文件管理工具"
arch=(
'aarch64'
@@ -17,25 +17,27 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'lib32-glibc'
'java-runtime'
- 'lib32-gcc-libs'
'python'
'nodejs'
)
options=('!strip')
-source=("${pkgname%-bin}.sh")
+source=(
+ "LICENSE.html::${url}/privacy-agreement.html"
+ "${pkgname%-bin}.sh"
+)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::https://ec.cnd.nantiangzzx.com/${_pkgname}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::https://ec.cnd.nantiangzzx.com/${_pkgname}_${pkgver}_amd64.deb")
-sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums=('cc65895a835817a900c9c2c4006a1738a6f2284cfa29eeb8283fd0043121931e'
+ 'f80acf84a87f3f50d7c4e2ed22f4d0e8b09dd98a6c26253f2524e5413771eab1')
sha256sums_aarch64=('5ad55272b26a667cfcca3cc8c31b0afdabae8c718694b645cb19c83dc7387838')
sha256sums_x86_64=('c3cd799babbfca9a6c367891ed8612279bb59dd78ff93a374c304e9f69d78d43')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin} --no-sandbox|${pkgname%-bin}|g;s|Development|Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
@@ -50,4 +52,5 @@ package() {
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/aechoterm.sh b/aechoterm.sh
index aacd8f895847..e6784b369c25 100644
--- a/aechoterm.sh
+++ b/aechoterm.sh
@@ -1,15 +1,15 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file