summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-03-16 16:46:38 +0100
committerhaawda2019-03-16 16:46:38 +0100
commit0cccc466c432355f49304252c1e3be14c329f39b (patch)
tree658d8a40b13aa63777cb98b488224f27961b7aa6
downloadaur-0cccc466c432355f49304252c1e3be14c329f39b.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--fix_help_and_init_file.patch63
3 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c5ae0d0057b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = aee-git
+ pkgdesc = Classic text editor with both curses and X11 interfaces.
+ pkgver = 2.2.21r4.ed7aa90
+ pkgrel = 1
+ url = https://github.com/xenji/aee.git
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ makedepends = git
+ source = git+https://github.com/xenji/aee.git
+ source = fix_help_and_init_file.patch
+ sha256sums = SKIP
+ sha256sums = 328ba28c07512c7044e7438e91908af80e97685942f34be2b6426bf7df640e85
+
+pkgname = aee-git
+ depends = glibc
+ provides = aee
+ conflicts = aee
+
+pkgname = xae-git
+ depends = libx11
+ depends = aee-git
+ provides = xae
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f1b00a02cd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=('aee-git' 'xae-git')
+pkgver=2.2.21r4.ed7aa90
+pkgrel=1
+pkgdesc="Classic text editor with both curses and X11 interfaces."
+arch=('i686' 'x86_64')
+url="https://github.com/xenji/aee.git"
+license=('PerlArtistic')
+makedepends=('git')
+source=("git+$url" fix_help_and_init_file.patch)
+sha256sums=('SKIP'
+ '328ba28c07512c7044e7438e91908af80e97685942f34be2b6426bf7df640e85')
+
+pkgver() {
+ cd ${pkgbase%-git}
+ printf "%sr%s.%s" $(awk -F\" '/AEE_VERSION/ {print $2}' aee_version.h ) $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd ${pkgbase%-git}
+ patch -Np1 < "$srcdir"/fix_help_and_init_file.patch
+}
+
+build() {
+ cd ${pkgbase%-git}
+ make
+ make xae
+}
+
+package_aee-git() {
+ depends=('glibc')
+ provides=('aee')
+ conflicts=('aee')
+
+ cd ${pkgbase%-git}
+ install -Dpm644 aee.1 "$pkgdir"/usr/share/man/man1/aee.1
+ install -Dpm644 help.ae "$pkgdir"/usr/share/$pkgname/help.ae
+ install -Dpm644 README.aee "$pkgdir"/usr/share/doc/$pkgname/README.aee
+ install -Dpm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
+ install -Dpm644 aee.1.ps "$pkgdir"/usr/share/doc/$pkgname/aee.1.ps
+ install -Dpm755 aee "$pkgdir"/usr/bin/aee
+}
+
+package_xae-git() {
+ depends=('libx11' 'aee-git')
+ provides=('xae')
+ cd ${pkgbase%-git}
+ install -Dpm755 xae "$pkgdir"/usr/bin/xae
+}
diff --git a/fix_help_and_init_file.patch b/fix_help_and_init_file.patch
new file mode 100644
index 000000000000..2cae22451a0a
--- /dev/null
+++ b/fix_help_and_init_file.patch
@@ -0,0 +1,63 @@
+diff --git a/aee.c b/aee.c
+index 3317576..d5cc8fb 100755
+--- a/aee.c
++++ b/aee.c
+@@ -2627,8 +2627,7 @@ char *string;
+ }
+
+ char *init_name[6] = {
+- "/usr/local/aee/init.ae",
+- "/usr/local/lib/init.ae",
++ "/etc/aee/init.ae",
+ NULL, /* to be ~/.init.ae */
+ ".init.ae",
+ NULL, /* to be ~/.aeerc */
+diff --git a/help.ae b/help.ae
+index f77f031..685a99a 100755
+--- a/help.ae
++++ b/help.ae
+@@ -1058,11 +1058,11 @@ init.ae
+
+ The file 'init.ae' may be used to set parameters and define keys to
+ perform certain functions within ae. This file may reside in three
+-locations: /usr/local/lib/init.ae, .init.ae in your home directory, and
++locations: /etc/aee/init.ae, .init.ae in your home directory, and
+ .init.ae in the current working directory.
+
+ First, aee checks for a system level initialization file, located in
+-/usr/local/lib. Next the user's home directory is checked for a file named
++/etc/aee. Next the user's home directory is checked for a file named
+ .init.ae, then the current directory. The settings from each file are read,
+ so that the directives from the most recently read file will take precedence
+ over previously read files. This allows, for example, the .init.ae file in
+diff --git a/help.c b/help.c
+index b19f435..41a7f35 100755
+--- a/help.c
++++ b/help.c
+@@ -10,11 +10,8 @@
+
+ #include "aee.h"
+
+-char *help_file_list[4] = {
+- "/usr/local/aee/help.ae",
+- "/usr/local/lib/help.ae",
+- "~/.help.ae",
+- "help.ae"
++char *help_file_list[1] = {
++ "/usr/share/aee/help.ae"
+ };
+
+ void
+diff --git a/localize.c b/localize.c
+index 9bcd989..29b41d3 100755
+--- a/localize.c
++++ b/localize.c
+@@ -64,7 +64,7 @@ strings_init()
+ catalog = catopen("aee", 0);
+ #endif /* NO_CATGETS */
+
+- ae_help_file = catgetlocal( 1, "/usr/local/lib/help.ae");
++ ae_help_file = catgetlocal( 1, "/usr/share/aee/help.ae");
+ main_buffer_name = catgetlocal( 2, "main");
+
+