summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-11-17 13:35:39 -0500
committerJames An2015-11-17 13:35:39 -0500
commitb26f9a4f798f0b11c2e6fb42ea7ae854b5edd08e (patch)
treeb0fb7b5e5707f3885fb75dea755fc3ed75f6dc91
parent0321c06f3f005d43db7d943ac4dccf4c10f840b0 (diff)
downloadaur-b26f9a4f798f0b11c2e6fb42ea7ae854b5edd08e.tar.gz
Addd system-wide http group-writable shared cache folders.
-rwxr-xr-xPKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1092835dd073..1c75181bf9b5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,7 +67,8 @@ package() {
install -Dm644 php-fpm.systemd.conf "$pkgdir/usr/lib/systemd/system/php-fpm.service.d/aegir.conf"
msg2 'Creating $pkgname directory structure'
- install --directory --owner=http --group=http --mode=6775 "$pkgdir/etc/drush" "$pkgdir/usr/share/webapps/$pkgname"
+ install --directory --owner=http --group=http --mode=6775 "$pkgdir/etc/drush"{,/cache{,/{complete,default,download,usage}}}
+ install --directory --owner=http --group=http --mode=6775 "$pkgdir/usr/share/webapps/$pkgname"
install --directory --owner=http --group=http --mode=0700 "$pkgdir/usr/share/webapps/$pkgname/.ssh"{,/ctrl-sockets}
mkdir -p "$pkgdir/srv/http" "$pkgdir/etc/skel"
ln -s /etc/drush "$pkgdir/srv/http/.drush"