summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2017-04-03 06:54:26 -0400
committerJames An2017-04-03 06:54:26 -0400
commitddde54ec79c56fed5ed4486f5608ee4e220ed316 (patch)
treee1d8fc0cad057f06535908446afa873dfc61e7c2
parente6ab05e088f24028290884a9321d08012ac26b77 (diff)
downloadaur-ddde54ec79c56fed5ed4486f5608ee4e220ed316.tar.gz
Moved conf files to new /etc conf directory, disabled the 'www' pool, and added debugging conf values to show php errors.
-rw-r--r--PKGBUILD4
-rw-r--r--aegir.install3
-rw-r--r--php-fpm.conf8
3 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22c266b38238..033e700e0f8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ package() {
install -dm750 "$pkgdir/etc/sudoers.d"
install -Dm644 msmtprc "$pkgdir/etc/msmtprc.$pkgname"
install -Dm644 nginx.conf "$pkgdir/etc/nginx/$pkgname.conf"
- install -Dm644 php-fpm.conf "$pkgdir/etc/php/fpm.d/$pkgname.conf"
+ install -Dm644 php-fpm.conf "$pkgdir/etc/php/php-fpm.d/$pkgname.conf"
install -Dm400 sudoers "$pkgdir/etc/sudoers.d/$pkgname"
install -Dm644 --owner=http --group=http <( ) "$pkgdir/var/spool/cron/$pkgname"
@@ -57,7 +57,7 @@ package() {
install -Dm644 "$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
install -Dm644 "$pkgname.target" "$pkgdir/usr/lib/systemd/system/$pkgname.target"
install -Dm644 nginx.systemd.conf "$pkgdir/usr/lib/systemd/system/nginx.service.d/aegir.conf"
- install -Dm644 php-fpm.systemd.conf "$pkgdir/usr/lib/systemd/system/php-fpm.service.d/aegir.conf"
+ #~ install -Dm644 php-fpm.systemd.conf "$pkgdir/usr/lib/systemd/system/php-fpm.service.d/aegir.conf"
msg2 'Creating $pkgname directory structure'
install --directory --owner=http --group=http --mode=ug=rwxs,o=rx "$pkgdir/etc/drush"{,/cache{,/{complete,default,download,usage}}}
diff --git a/aegir.install b/aegir.install
index 5001df18f60e..986065520ddf 100644
--- a/aegir.install
+++ b/aegir.install
@@ -7,6 +7,9 @@ post_install() {
echo -n ">>> Testing for successful outgoing mail by PHP... "
[ -z "$(php -r 'print_r(mail("example@example.com", "Test email from PHP", "Test email body."));')" ] && echo "Failed." || echo "Passed."
+ echo -n ">>> Disabling default pool named 'www' by commenting out all non-empty lines without a semi-colon prefix..."
+ sed --in-place 's/^\([^$;]\)/;\1/' /etc/php/php-fpm.d/www.conf
+
echo ">>> Initialise Aegir with the following steps:"
echo " 1. Initialise the MariaDB data directory, e.g. with the mysql install db command, and start the MariaDB service:"
echo " # mysql_install_db --user=mysql --basedir=/usr --datadir=/var/lib/mysql && systemctl start mysqld.service"
diff --git a/php-fpm.conf b/php-fpm.conf
index d63cef2ab430..a026e16d2144 100644
--- a/php-fpm.conf
+++ b/php-fpm.conf
@@ -1,7 +1,3 @@
-[global]
-pid = /run/php-fpm/php-fpm.pid
-daemonize = no
-
[aegir]
user = aegir
group = http
@@ -20,5 +16,7 @@ pm.min_spare_servers = 1
pm.max_spare_servers = 3
php_admin_flag[allow_url_fopen] = off
+php_admin_flag[display_errors] = on
+php_admin_flag[display_startup_errors] = on
php_admin_flag[expose_php] = off
-php_admin_value[error_reporting] = E_ALL
+php_admin_value[error_reporting] = E_ALL | E_STRICT