summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-11-18 22:31:13 -0500
committerJames An2015-11-18 22:31:13 -0500
commit0a82658b96b695ef5f9e7c096f02bf4e127398a8 (patch)
tree000209b40074192966287fad510c88e31a2e2f17
parent9fd38ee05fd263120a4340201c44a3ef0f91f20f (diff)
downloadaur-0a82658b96b695ef5f9e7c096f02bf4e127398a8.tar.gz
Updated prepare() function to explicitly use Drupal 7 and ignore dev versions of extensions.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6090877570fb..446b737e9e5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegir-hostmaster
pkgdesc = mass Drupal hosting system - frontend
pkgver = 7.x_3.2
- pkgrel = 2
+ pkgrel = 3
url = http://aegirproject.org
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index c17c197fb16a..d60be6550947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=hostmaster
pkgname=aegir-$_pkgname
pkgver=7.x_3.2
-pkgrel=2
+pkgrel=3
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
@@ -22,7 +22,7 @@ prepare() {
for TYPE in modules themes; do
for DIR in $_pkgname/profiles/$_pkgname/$TYPE/*/*; do
EXT=$(basename $DIR)
- VER_DO=$(drush rl $EXT --fields=version,status --pipe |& grep Supported | head -n1 | cut -f1 -d,)
+ VER_DO=$(drush rl --default-major=7 $EXT --fields=version,status --pipe |& grep -v -- '-dev' | grep Supported | head -n1 | cut -f1 -d,)
VER_HM=$(grep 'version = ' $DIR/$EXT.info | tail -n1 | cut -f2 -d\")
if [[ "$VER_HM" < "$VER_DO" ]]; then
msg2 " Fetching $EXT..."