summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2017-01-27 18:14:11 -0500
committerJames An2017-01-27 18:15:08 -0500
commit18a09d1732d758e1a3d7202e2874defaa858235c (patch)
tree8af25911b54740a05d5af7ff18ae69662642aa99
parent9a4d6eea736d8755b746a9e55c604f82bcee55e7 (diff)
downloadaur-18a09d1732d758e1a3d7202e2874defaa858235c.tar.gz
Updated to latest upstream release, added a patch for a hosting module bug and a patch to add packaging info to the hosting_https module, and converted the hosting_https module source to its authoritative git repository master HEAD as its in active development.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch13
-rw-r--r--hosting_https-pkg-info.patch14
4 files changed, 60 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6b003babb9f..cacc3d391d8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = aegir-hostmaster
pkgdesc = mass Drupal hosting system - frontend
- pkgver = 7.x_3.9_beta1
- pkgrel = 4
+ pkgver = 7.x_3.9
+ pkgrel = 1
url = http://aegirproject.org
arch = any
license = GPL
depends = drush>=7
- source = https://ftp.drupal.org/files/projects/hostmaster-7.x-3.9-beta1-no-core.tar.gz
+ source = https://ftp.drupal.org/files/projects/hostmaster-7.x-3.9-no-core.tar.gz
source = https://ftp.drupal.org/files/projects/devel_debug_log-7.x-1.2.tar.gz
source = https://ftp.drupal.org/files/projects/devel-7.x-1.5.tar.gz
- source = https://ftp.drupal.org/files/projects/drupal-7.51.tar.gz
- source = https://gitlab.com/aegir/hosting_https/repository/archive.tar.gz?ref=master
+ source = https://ftp.drupal.org/files/projects/drupal-7.53.tar.gz
source = https://github.com/lukas2511/dehydrated/archive/master.tar.gz
- md5sums = ce4c49a5c3325505b266201e0cdc4a48
+ source = hosting_https::git+https://gitlab.com/aegir/hosting_https.git
+ source = hosting_https-pkg-info.patch
+ source = hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch
+ md5sums = 6d27c8b0de71db7c6e2b041da25c5fef
md5sums = 19561aa1a0f2e549acf5c44a8cad8e14
md5sums = f06c912eb4edbd48fbcc2867516726a3
- md5sums = 49f82c1cac8e4bd4941ca160fcbee93d
- md5sums = e39904682de04c044d518a6f1f173e26
+ md5sums = 4230279ecca4f0cde652a219e10327e7
md5sums = 62f0351d36f900884705207922d5c7d5
+ md5sums = SKIP
+ md5sums = da16dba10759dfa59c7d760419f3f042
+ md5sums = faa872c26a49c62d841574ae10a43a20
pkgname = aegir-hostmaster
diff --git a/PKGBUILD b/PKGBUILD
index 7c9b76d3efc7..af754255720f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,45 @@
pkgname=aegir-hostmaster
_pkgname=${pkgname#aegir-}
-pkgver=7.x_3.9_beta1
-pkgrel=4
+pkgver=7.x_3.9
+pkgrel=1
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
license=('GPL')
depends=('drush>=7')
+makedepends=('git')
source=("https://ftp.drupal.org/files/projects/$_pkgname-${pkgver//_/-}-no-core.tar.gz"
'https://ftp.drupal.org/files/projects/devel_debug_log-7.x-1.2.tar.gz'
'https://ftp.drupal.org/files/projects/devel-7.x-1.5.tar.gz'
- 'https://ftp.drupal.org/files/projects/drupal-7.51.tar.gz'
- 'https://gitlab.com/aegir/hosting_https/repository/archive.tar.gz?ref=master'
- 'https://github.com/lukas2511/dehydrated/archive/master.tar.gz')
-md5sums=('ce4c49a5c3325505b266201e0cdc4a48'
+ 'https://ftp.drupal.org/files/projects/drupal-7.53.tar.gz'
+ 'https://github.com/lukas2511/dehydrated/archive/master.tar.gz'
+ 'hosting_https'::'git+https://gitlab.com/aegir/hosting_https.git'
+ hosting_https-pkg-info.patch
+ hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch)
+md5sums=('6d27c8b0de71db7c6e2b041da25c5fef'
'19561aa1a0f2e549acf5c44a8cad8e14'
'f06c912eb4edbd48fbcc2867516726a3'
- '49f82c1cac8e4bd4941ca160fcbee93d'
- 'e39904682de04c044d518a6f1f173e26'
- '62f0351d36f900884705207922d5c7d5')
+ '4230279ecca4f0cde652a219e10327e7'
+ '62f0351d36f900884705207922d5c7d5'
+ 'SKIP'
+ 'da16dba10759dfa59c7d760419f3f042'
+ 'faa872c26a49c62d841574ae10a43a20')
+
+prepare() {
+ patch --directory=hosting_https --strip=1 < hosting_https-pkg-info.patch
+ patch --directory="$_pkgname/modules/aegir/hosting" --strip=1 < hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch
+}
package() {
install -d $pkgdir/{var/lib,usr/share/webapps}/$_pkgname
- cp -a drupal-7.51/* "$pkgdir/usr/share/webapps/$_pkgname"
+ cp -a drupal-7.53/* "$pkgdir/usr/share/webapps/$_pkgname"
cp -a $_pkgname "$pkgdir/usr/share/webapps/$_pkgname/profiles/$_pkgname"
mv "$pkgdir/usr/share/webapps/$_pkgname/sites" "$pkgdir/var/lib/$_pkgname"
ln -s "/var/lib/$_pkgname/sites" "$pkgdir/usr/share/webapps/$_pkgname"
cp -a devel devel_debug_log "$pkgdir/var/lib/$_pkgname/sites/all/modules"
- cp -aT hosting_https-master-* "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https"
+ cp -aT hosting_https "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https"
cp -aT dehydrated-master "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https/submodules/letsencrypt/drush/bin/letsencrypt"
install -D <( ) "$pkgdir/var/lib/$_pkgname/sites/all/drush/drushrc.php"
diff --git a/hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch b/hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch
new file mode 100644
index 000000000000..977834aa0f9f
--- /dev/null
+++ b/hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch
@@ -0,0 +1,13 @@
+diff --git a/task.hosting.inc b/task.hosting.inc
+index 2c393ce..01c5a90 100644
+--- a/task.hosting.inc
++++ b/task.hosting.inc
+@@ -127,7 +127,7 @@ function drush_hosting_task() {
+ $hook = 'hosting_' . $task->ref->type . '_context_options';
+ foreach (module_implements($hook) as $module) {
+ $function = $module . '_' . $hook;
+- call_user_func($function, $task);
++ call_user_func_array($function, array(&$task));
+ }
+
+ drush_invoke_process('@none', 'provision-save', array('@' . $task->ref->hosting_name), $task->context_options, array('method' => $mode, 'integrate' => TRUE));
diff --git a/hosting_https-pkg-info.patch b/hosting_https-pkg-info.patch
new file mode 100644
index 000000000000..35345c23e58f
--- /dev/null
+++ b/hosting_https-pkg-info.patch
@@ -0,0 +1,14 @@
+diff --git a/hosting_https.info b/hosting_https.info
+index 965395b..3c2bea1 100644
+--- a/hosting_https.info
++++ b/hosting_https.info
+@@ -7,3 +7,9 @@ dependencies[] = hosting_certificate
+ core = 7.x
+
+ files[] = hosting_https.service.inc
++
++; Information added via an AUR patch on 2016-01-27
++version = "7.x-3.x"
++core = "7.x"
++project = "hosting_https"
++datestamp = "1485557017"