summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-09-10 09:07:19 -0400
committerJames An2014-09-10 09:07:19 -0400
commit20da1008eda5c7f93cce997380ee3a73a480c23d (patch)
treecb9f27e10f6a69df7e5b68a376713a16df5f7be8
parentfba6874ff4ff682c23108f904929a655c0b68138 (diff)
downloadaur-20da1008eda5c7f93cce997380ee3a73a480c23d.tar.gz
Completed aegir-hostmaster (nginx variant)
-rw-r--r--PKGBUILD30
-rw-r--r--aegir-hostmaster.install21
-rw-r--r--php-fpm.conf9
-rw-r--r--php-fpm.svc.conf3
-rw-r--r--php.ini (renamed from aegir.ini)0
-rw-r--r--service (renamed from systemd.service)0
-rw-r--r--sudoers (renamed from nginx.sudoers)0
7 files changed, 41 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e33817df0540..1daa6cfd6fc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aegir-hostmaster
_pkgname=hostmaster
pkgver=2.1
-pkgrel=1
+pkgrel=2
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
@@ -25,21 +25,26 @@ optdepends=(
'php-fpm: for nginx support'
)
install=$pkgname.install
+options=(!upx !strip)
source=(
"http://ftp.drupal.org/files/projects/${_pkgname}-6.x-${pkgver}-core.tar.gz"
- 'aegir.ini'
+ 'php.ini'
+ 'php-fpm.conf'
+ 'php-fpm.svc.conf'
'nginx.conf'
'nginx.svc.conf'
- 'nginx.sudoers'
- 'systemd.service'
+ 'service'
+ 'sudoers'
)
md5sums=(
'381e904e8eed14c9aa574c6ed133d38b'
'6bd6a1c6264fe7c06d79d1f5159b1e68'
+ '09c2c8581f7517b64044c2368e5901b3'
+ 'e052eeae1565fcd35550900003ffa840'
'a849c7594eedec0ef415b972da048815'
'e8b6c3748c26caf4af21d402e7a0b947'
- '21178d56a58133e39309dd98d94409cc'
'675f8f7b0bec18b3a02c6a5db5de5360'
+ '21178d56a58133e39309dd98d94409cc'
)
package() {
@@ -60,12 +65,14 @@ package() {
msg2 'Adding misc config files'
cd ..
- install -Dm644 aegir.ini "${pkgdir}/etc/php/conf.d/10-aegir.ini"
- install -dm750 "${pkgdir}/etc/sudoers.d"
- install -Dm440 nginx.sudoers "${pkgdir}/etc/sudoers.d/aegir"
- install -Dm644 nginx.conf "${pkgdir}/etc/nginx/aegir.conf"
- install -Dm644 systemd.service "${pkgdir}/usr/lib/systemd/system/aegir.service"
- install -Dm644 nginx.svc.conf "${pkgdir}/usr/lib/systemd/system/nginx.service.d/aegir.conf"
+ install -Dm644 php.ini "${pkgdir}/etc/php/conf.d/aegir.ini"
+ install -dm750 "${pkgdir}/etc/sudoers.d"
+ install -Dm440 sudoers "${pkgdir}/etc/sudoers.d/aegir"
+ install -Dm644 php-fpm.conf "${pkgdir}/etc/php/fpm.d/aegir.conf"
+ install -Dm644 nginx.conf "${pkgdir}/etc/nginx/aegir.conf"
+ install -Dm644 service "${pkgdir}/usr/lib/systemd/system/aegir.service"
+ install -Dm644 php-fpm.svc.conf "${pkgdir}/usr/lib/systemd/system/php-fpm.service.d/aegir.conf"
+ install -Dm644 nginx.svc.conf "${pkgdir}/usr/lib/systemd/system/nginx.service.d/aegir.conf"
mkdir -p "{pkgdir}/var/lib/aegir/{backups,clients,config/{includes,self,server_localhost,server_master/nginx/{platform,post,pre,subdir,platform}.d},platforms}"
install -dm755 "${pkgdir}/var/lib/aegir/config"
ln -sr /var/lib/aegir/config/server_master/nginx.conf "${pkgdir}/var/lib/aegir/config/nginx.conf"
@@ -75,5 +82,4 @@ package() {
find "${pkgdir}/usr/share/webapps/aegir" -type d -exec chmod 0755 {} +
find "${pkgdir}/var/lib/aegir" -type f -exec chmod 0644 {} +
find "${pkgdir}/var/lib/aegir" -type d -exec chmod 0755 {} +
-
}
diff --git a/aegir-hostmaster.install b/aegir-hostmaster.install
index 7aaccdc5706a..4c677ab4f814 100644
--- a/aegir-hostmaster.install
+++ b/aegir-hostmaster.install
@@ -2,17 +2,18 @@ post_install() {
post_upgrade
passwd -l aegir &>/dev/null
- echo ">>> This machine's hostname must be a FQDN that resolves to its IP address."
- echo ">>> MariaDB must be initialised with:"
- echo ">>> # /usr/bin/mysql_secure_installation"
- echo ">>> before Aegir can be used."
- echo ">>> It's strongly recommended to create a separate, password-protected MySQL"
- echo ">>> root account for Aegir by running as MySQL root:"
- echo ">>> # GRANT ALL PRIVILEGES ON *.* TO 'aegir_root'@'%' IDENTIFIED BY "
- echo ">>> 'password' WITH GRANT OPTION;"
- echo ">>> $ drush hostmaster-install --web_group=http [--http_service_type=nginx] \\"
- echo ">>> [--aegir_db_user=root --aegir_db_pass=root] \\"
+ echo ">>> 1. Ensure this machine's hostname is a FQDN that resolves one of its IP addresses"
+ echo ">>> 2. Init. MariaDB: start mysqld.service and run as root /usr/bin/mysql_secure_installation"
+ echo ">>> 3. Create a separate MySQL account for Aegir by running as MySQL root:"
+ echo ">>> # GRANT ALL PRIVILEGES ON *.* TO 'aegir_root'@'%' IDENTIFIED BY 'password' WITH GRANT OPTION;"
+ echo ">>> 4. Verify that the smtp-forwarder is working and mail can be sent"
+ echo ">>> 4. Start the php-fpm, cron, service units (nginx will start after)"
+ echo ">>> 5. Install hostmaster by running as the aegir user:"
+ echo ">>> \$ drush hostmaster-install --web_group=http [--http_service_type=nginx] \\"
+ echo ">>> --root=/usr/share/webapps/aegir [--aegir_db_user=USER --aegir_db_pass=PASS] \\"
echo ">>> --aegir_host=FQDN [--client_email=email] FQDN"
+ echo ">>> 6. Start the nginx service unit and enable start at boot: php-fpm, nginx, cron, mysqld units."
+ echo ">>> 7. Use the provided one-time root user login to log into Aegir's frontend."
}
post_upgrade() {
diff --git a/php-fpm.conf b/php-fpm.conf
new file mode 100644
index 000000000000..0e3cf17bd1b3
--- /dev/null
+++ b/php-fpm.conf
@@ -0,0 +1,9 @@
+;;;;;;;;;;;;;;;;;;;;
+; Aegir FPM Config ;
+;;;;;;;;;;;;;;;;;;;;
+
+[www]
+listen = 127.0.0.1:9000
+
+[global]
+include=/etc/php/php-fpm.conf
diff --git a/php-fpm.svc.conf b/php-fpm.svc.conf
new file mode 100644
index 000000000000..c59abd6829af
--- /dev/null
+++ b/php-fpm.svc.conf
@@ -0,0 +1,3 @@
+[Service]
+ExecStart=
+ExecStart=/usr/bin/php-fpm --nodaemonize --pid /run/php-fpm/php-fpm.pid --fpm-config /etc/php/fpm.d/aegir.conf
diff --git a/aegir.ini b/php.ini
index f70793376886..f70793376886 100644
--- a/aegir.ini
+++ b/php.ini
diff --git a/systemd.service b/service
index 9377635e463c..9377635e463c 100644
--- a/systemd.service
+++ b/service
diff --git a/nginx.sudoers b/sudoers
index c9a588981086..c9a588981086 100644
--- a/nginx.sudoers
+++ b/sudoers