summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-12-09 02:08:45 -0500
committerJames An2014-12-09 02:08:45 -0500
commit4351a4dff4ca0fda37708c4b116d43c152ad2c14 (patch)
tree0d72648dc9c5950038a826e2b844e803da742a74
parentec3885ee019999db574e0f880a4f1d717dd0c235 (diff)
downloadaur-4351a4dff4ca0fda37708c4b116d43c152ad2c14.tar.gz
Upgraded aegir-hostmaster and aegir-provision to latest upstream release.
-rw-r--r--PKGBUILD48
-rw-r--r--php-fpm.conf2
2 files changed, 33 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01ab0ed25f71..77555dfa0a92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=aegir-hostmaster
_pkgname=hostmaster
-pkgver=2.1
-pkgrel=4
+pkgver=3.0_alpha1
+pkgrel=1
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
@@ -11,6 +11,8 @@ license=('GPL')
depends=(
'aegir-provision'
'cron'
+ 'nginx'
+ 'php-fpm'
'php-gd'
'rsync'
'mariadb'
@@ -18,16 +20,11 @@ depends=(
'smtp-forwarder'
'unzip'
)
-optdepends=(
- 'apache: for apache support'
- 'php-apache: for apache support'
- 'nginx: for nginx support'
- 'php-fpm: for nginx support'
-)
install=$pkgname.install
options=(!upx !strip)
source=(
- "http://ftp.drupal.org/files/projects/${_pkgname}-6.x-${pkgver}-core.tar.gz"
+ "http://ftp.drupal.org/files/projects/${_pkgname}-7.x-${pkgver/_/-}-core.tar.gz"
+ 'http://ftp.drupal.org/files/projects/devel-7.x-1.5.tar.gz'
'php.ini'
'php-fpm.conf'
'php-fpm.svc.conf'
@@ -35,18 +32,25 @@ source=(
'nginx.svc.conf'
'service'
'sudoers'
+ 'http://ftp.drupal.org/files/projects/eldir-7.x-3.0-alpha1.tar.gz'
+ 'http://ftp.drupal.org/files/projects/hosting-7.x-3.0-alpha1.tar.gz'
+ 'http://ftp.drupal.org/files/projects/hosting_platform_pathauto-7.x-2.1.tar.gz'
)
-md5sums=('381e904e8eed14c9aa574c6ed133d38b'
+md5sums=('ec94749f5b4d2243bba9ceda8ee62ca8'
+ 'f06c912eb4edbd48fbcc2867516726a3'
'6bd6a1c6264fe7c06d79d1f5159b1e68'
- 'c6d35d7fde52d628b13d1d65be8ff782'
+ 'e3c0a33e3ce714b4fdbd2e30416456c2'
'e052eeae1565fcd35550900003ffa840'
'a849c7594eedec0ef415b972da048815'
'e8b6c3748c26caf4af21d402e7a0b947'
'675f8f7b0bec18b3a02c6a5db5de5360'
- '21178d56a58133e39309dd98d94409cc')
+ '21178d56a58133e39309dd98d94409cc'
+ '5f168aedc6800fd3620fbc46d48c88a9'
+ '665c01ba1a5b44b2ccb163d99a518240'
+ '70d7c42d55588e59646526a4afc2a7f5')
package() {
- cd "${_pkgname}-6.x-${pkgver}"
+ cd "${_pkgname}-7.x-${pkgver/_/-}"
msg2 'Adding hostmaster site files'
install -m755 -d "${pkgdir}/var/lib/aegir/hostmaster"
@@ -57,11 +61,20 @@ package() {
install -m755 -d "${pkgdir}/usr/share/webapps/aegir"
ln -s /var/lib/aegir/hostmaster/sites "${pkgdir}/usr/share/webapps/aegir"
mv * "${pkgdir}/usr/share/webapps/aegir"
- find "${pkgdir}/usr/share/webapps/aegir" -type f -exec chmod 0644 {} +
- find "${pkgdir}/usr/share/webapps/aegir" -type d -exec chmod 0755 {} +
+
+ # Known issue: http://community.aegirproject.org/3.0-alpha1
+ msg2 'Adding devel module (known 7.x-3.0-alpha1 bug)'
+ cd $srcdir
+ install -m755 -d "${pkgdir}/var/lib/aegir/hostmaster/sites/all/modules"
+ mv devel "${pkgdir}/var/lib/aegir/hostmaster/sites/all/modules"
+
+ # Upgrading modules
+ mv eldir "${pkgdir}/var/lib/aegir/hostmaster/sites/all/modules"
+ mv hosting "${pkgdir}/var/lib/aegir/hostmaster/sites/all/modules"
+ mv hosting_platform_pathauto "${pkgdir}/var/lib/aegir/hostmaster/sites/all/modules"
msg2 'Adding misc config files'
- cd ..
+ cd $srcdir
install -Dm644 php.ini "${pkgdir}/etc/php/conf.d/aegir.ini"
install -dm750 "${pkgdir}/etc/sudoers.d"
install -Dm440 sudoers "${pkgdir}/etc/sudoers.d/aegir"
@@ -71,7 +84,7 @@ package() {
install -Dm644 php-fpm.svc.conf "${pkgdir}/usr/lib/systemd/system/php-fpm.service.d/aegir.conf"
install -Dm644 nginx.svc.conf "${pkgdir}/usr/lib/systemd/system/nginx.service.d/aegir.conf"
mkdir -p "{pkgdir}/var/lib/aegir/{backups,clients,config/{includes,self,server_localhost,server_master/nginx/{platform,post,pre,subdir,platform}.d},platforms}"
- install -dm755 "${pkgdir}/var/lib/aegir/config"
+ install -dm711 "${pkgdir}/var/lib/aegir/config"
ln -sr /var/lib/aegir/config/server_master/nginx.conf "${pkgdir}/var/lib/aegir/config/nginx.conf"
msg2 'Applying file permissions'
@@ -81,4 +94,5 @@ package() {
find "${pkgdir}/usr/share/webapps/aegir" -type d -exec chmod 0755 {} +
find "${pkgdir}/var/lib/aegir" -type f -exec chmod 0644 {} +
find "${pkgdir}/var/lib/aegir" -type d -exec chmod 0755 {} +
+ chmod -R ga-rwx "${pkgdir}/var/lib/aegir/config"
}
diff --git a/php-fpm.conf b/php-fpm.conf
index 71c58579d020..4f7295f8b9f9 100644
--- a/php-fpm.conf
+++ b/php-fpm.conf
@@ -7,3 +7,5 @@ include=/etc/php/php-fpm.conf
[www]
listen = 127.0.0.1:9000
+user = aegir
+group = aegir