summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2017-02-21 19:01:49 -0500
committerJames An2017-02-21 19:01:49 -0500
commit842b4c1ac69c76a4caa47c2f49793f868424b027 (patch)
treed46c5ca1ce1fbbe6aadc3571b2bf80714e35b37e
parentf448d8d4ab297061e3396c43a7029fa0896836a7 (diff)
downloadaur-842b4c1ac69c76a4caa47c2f49793f868424b027.tar.gz
Patched all web server restart SysV commands with systemd equivalents.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97d002649483..2057e60c0407 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegir-hostmaster
pkgdesc = mass Drupal hosting system - frontend
pkgver = 7.x_3.9
- pkgrel = 4
+ pkgrel = 5
url = http://aegirproject.org
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index bdee3f452982..dabfdf89e627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aegir-hostmaster
_pkgname=${pkgname#aegir-}
pkgver=7.x_3.9
-pkgrel=4
+pkgrel=5
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
@@ -29,6 +29,22 @@ md5sums=('6d27c8b0de71db7c6e2b041da25c5fef'
prepare() {
patch --directory=hosting_https --strip=1 < hosting_https-pkg-info.patch
patch --directory="$_pkgname/modules/aegir/hosting" --strip=1 < hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch
+
+ local -A expr=(
+ [nginx_stub]='/\/etc\/init.d\/nginx/c \ return "sudo /usr/bin/systemctl try-reload-or-restart httpd.service";''/\/etc\/init.d\/nginx/c \ return "sudo /usr/bin/systemctl try-reload-or-restart httpd.service";'
+ [apache_apachectl]='/\/usr\/sbin\/apachectl/,/return/c \ return "sudo /usr/bin/systemctl try-reload-or-restart httpd.service";'
+ [apache_apache2ctl]='/\/usr\/sbin\/apache2ctl/,/return/c \ return "sudo /usr/bin/systemctl try-reload-or-restart httpd.service";'
+ )
+ local -A path=(
+ [nginx_stub]="$_pkgname/modules/aegir/hosting/web_server/nginx/hosting_nginx.service.inc $_pkgname/modules/aegir/hosting/web_server/nginx/ssl/hosting_nginx_ssl.service.inc hosting_https/submodules/nginx_https/hosting_nginx_https.service.inc"
+ [apache_apachectl]="$_pkgname/modules/aegir/hosting/web_server/ssl/hosting_ssl.service.inc hosting_https/submodules/apache_https/hosting_apache_https.service.inc"
+ [apache_apache2ctl]="$_pkgname/modules/aegir/hosting/web_server/hosting_web_server.service.inc"
+ )
+
+ for index in "${!expr[@]}"; do
+ # Apply word splitting to path string as its a space-separated list of files.
+ sed --in-place "${expr[$index]}" ${path[$index]}
+ done
}
package() {