summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-09-16 00:45:12 -0400
committerJames An2014-09-16 00:45:12 -0400
commita8ede03760ea28ea282b8633973a35da2d482a72 (patch)
tree06355873635074342c2ef0e00737470bda1ce76a
parent20da1008eda5c7f93cce997380ee3a73a480c23d (diff)
downloadaur-a8ede03760ea28ea282b8633973a35da2d482a72.tar.gz
Fixed aegir pkgs and added post-install instructions to complete its setup.
-rw-r--r--PKGBUILD32
-rw-r--r--aegir-hostmaster.install10
-rw-r--r--php-fpm.conf22
-rw-r--r--php.ini6
4 files changed, 40 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1daa6cfd6fc1..ab07458c45c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aegir-hostmaster
_pkgname=hostmaster
pkgver=2.1
-pkgrel=2
+pkgrel=3
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
@@ -13,12 +13,12 @@ depends=(
'cron'
'rsync'
'mariadb'
+ 'php-gd'
'sudo'
'smtp-forwarder'
'unzip'
)
optdepends=(
- 'php-gd: '
'apache: for apache support'
'php-apache: for apache support'
'nginx: for nginx support'
@@ -36,16 +36,14 @@ source=(
'service'
'sudoers'
)
-md5sums=(
- '381e904e8eed14c9aa574c6ed133d38b'
- '6bd6a1c6264fe7c06d79d1f5159b1e68'
- '09c2c8581f7517b64044c2368e5901b3'
- 'e052eeae1565fcd35550900003ffa840'
- 'a849c7594eedec0ef415b972da048815'
- 'e8b6c3748c26caf4af21d402e7a0b947'
- '675f8f7b0bec18b3a02c6a5db5de5360'
- '21178d56a58133e39309dd98d94409cc'
-)
+md5sums=('381e904e8eed14c9aa574c6ed133d38b'
+ '782e36c40b3432dafc37f69926c28237'
+ 'c6035a7b509a41fbd19100de12fae49d'
+ 'e052eeae1565fcd35550900003ffa840'
+ 'a849c7594eedec0ef415b972da048815'
+ 'e8b6c3748c26caf4af21d402e7a0b947'
+ '675f8f7b0bec18b3a02c6a5db5de5360'
+ '21178d56a58133e39309dd98d94409cc')
package() {
cd "${_pkgname}-6.x-${pkgver}"
@@ -78,8 +76,10 @@ package() {
ln -sr /var/lib/aegir/config/server_master/nginx.conf "${pkgdir}/var/lib/aegir/config/nginx.conf"
msg2 'Applying file mode bits'
- find "${pkgdir}/usr/share/webapps/aegir" -type f -exec chmod 0644 {} +
- find "${pkgdir}/usr/share/webapps/aegir" -type d -exec chmod 0755 {} +
- find "${pkgdir}/var/lib/aegir" -type f -exec chmod 0644 {} +
- find "${pkgdir}/var/lib/aegir" -type d -exec chmod 0755 {} +
+ find "${pkgdir}/var/lib/aegir" \
+ "${pkgdir}/usr/share/webapps/aegir" -type f -exec chmod 0644 {} +
+ find "${pkgdir}/var/lib/aegir" \
+ "${pkgdir}/usr/share/webapps/aegir" -type d -exec chmod 0755 {} +
+ chown -R 640:640 "${pkgdir}/var/lib/aegir" \
+ "${pkgdir}/usr/share/webapps/aegir"
}
diff --git a/aegir-hostmaster.install b/aegir-hostmaster.install
index 4c677ab4f814..2ffe1d1cb100 100644
--- a/aegir-hostmaster.install
+++ b/aegir-hostmaster.install
@@ -9,16 +9,16 @@ post_install() {
echo ">>> 4. Verify that the smtp-forwarder is working and mail can be sent"
echo ">>> 4. Start the php-fpm, cron, service units (nginx will start after)"
echo ">>> 5. Install hostmaster by running as the aegir user:"
- echo ">>> \$ drush hostmaster-install --web_group=http [--http_service_type=nginx] \\"
- echo ">>> --root=/usr/share/webapps/aegir [--aegir_db_user=USER --aegir_db_pass=PASS] \\"
- echo ">>> --aegir_host=FQDN [--client_email=email] FQDN"
+ echo ">>> \$ drush hostmaster-install --web_group=http --http_service_type=apache|nginx \\"
+ echo ">>> --root=/usr/share/webapps/aegir --aegir_db_user=aegir_root --aegir_db_pass=aegir_pass \\"
+ echo ">>> --aegir_host=FQDN --client_email=email@example.com FQDN"
echo ">>> 6. Start the nginx service unit and enable start at boot: php-fpm, nginx, cron, mysqld units."
echo ">>> 7. Use the provided one-time root user login to log into Aegir's frontend."
}
post_upgrade() {
# create user/group that the daemon will run as by default, do not delete this on uninstall, as it will own files
- getent group aegir >/dev/null || groupadd aegir
- getent passwd aegir >/dev/null || useradd -g aegir -G http,mail -b '/var/lib' -s /bin/bash aegir
+ getent group aegir >/dev/null || groupadd -g 640 aegir
+ getent passwd aegir >/dev/null || useradd -g 640 -u 640 -NG http,mail -b '/var/lib' -s /bin/bash aegir
}
diff --git a/php-fpm.conf b/php-fpm.conf
index 0e3cf17bd1b3..dea470467124 100644
--- a/php-fpm.conf
+++ b/php-fpm.conf
@@ -2,8 +2,24 @@
; Aegir FPM Config ;
;;;;;;;;;;;;;;;;;;;;
-[www]
+[global]
+pid = /run/php-fpm/php-fpm.pid
+
+[aegir]
+user = http
+group = http
+
listen = 127.0.0.1:9000
+;listen = /run/php-fpm/php-fpm.sock
+;listen.backlog = 65535
-[global]
-include=/etc/php/php-fpm.conf
+listen.owner = http
+listen.group = http
+listen.mode = 0660
+
+pm = dynamic
+pm.max_children = 5
+pm.start_servers = 2
+
+pm.min_spare_servers = 1
+pm.max_spare_servers = 3
diff --git a/php.ini b/php.ini
index f70793376886..447493c7d2d7 100644
--- a/php.ini
+++ b/php.ini
@@ -26,9 +26,3 @@ open_basedir =
;
date.timezone=UTC
memory_limit = 192M
-
-;
-; sendmail options
-;
-;sendmail_path = "/usr/bin/msmtp -C /etc/msmtprc -t" # msmtp
-;sendmail_path = "/usr/bin/sendmail -t" # SSMTP