summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2017-02-21 18:59:33 -0500
committerJames An2017-02-21 18:59:33 -0500
commitf448d8d4ab297061e3396c43a7029fa0896836a7 (patch)
tree809e30dcd2f729c2b2c526971d32467b76c1f43e
parent3bdb538bc74ba98d390fb6999110d8aabe0e6296 (diff)
downloadaur-f448d8d4ab297061e3396c43a7029fa0896836a7.tar.gz
Fixed installation of contrib modules to standard installation in sites/all module folder.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80bff29e7765..97d002649483 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegir-hostmaster
pkgdesc = mass Drupal hosting system - frontend
pkgver = 7.x_3.9
- pkgrel = 3
+ pkgrel = 4
url = http://aegirproject.org
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index cfa7ba5f17ba..bdee3f452982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aegir-hostmaster
_pkgname=${pkgname#aegir-}
pkgver=7.x_3.9
-pkgrel=3
+pkgrel=4
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
@@ -33,14 +33,15 @@ prepare() {
package() {
install -d $pkgdir/{var/lib,usr/share/webapps}/$_pkgname
+ install -d "$pkgdir/var/lib/$_pkgname/sites/all/modules"
install -d "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https/submodules/letsencrypt/drush/bin/letsencrypt/$_pkgname"
cp -a drupal-7.53/* "$pkgdir/usr/share/webapps/$_pkgname"
cp -a $_pkgname "$pkgdir/usr/share/webapps/$_pkgname/profiles/$_pkgname"
+ [ -d "$pkgdir/var/lib/$_pkgname" ] && rm --recursive "$pkgdir/var/lib/$_pkgname/sites"
mv "$pkgdir/usr/share/webapps/$_pkgname/sites" "$pkgdir/var/lib/$_pkgname"
ln -s "/var/lib/$_pkgname/sites" "$pkgdir/usr/share/webapps/$_pkgname"
- cp -a devel devel_debug_log "$pkgdir/var/lib/$_pkgname/sites/all/modules"
- cp -aT hosting_https "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https"
+ cp -a devel devel_debug_log hosting_https "$pkgdir/var/lib/$_pkgname/sites/all/modules"
ln -s /usr/bin/dehydrated "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https/submodules/letsencrypt/drush/bin/letsencrypt"
install -D <( ) "$pkgdir/var/lib/$_pkgname/sites/all/drush/drushrc.php"