summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-09-10 07:31:01 -0400
committerJames An2014-09-10 07:31:01 -0400
commitfba6874ff4ff682c23108f904929a655c0b68138 (patch)
tree4de8dac0137c7d3692d10e207b986f802eec9cc7
parent263b5eb73779e6a91057157298e53ff188d69ee7 (diff)
downloadaur-fba6874ff4ff682c23108f904929a655c0b68138.tar.gz
Added to aegir-hostmaster cron depends, install file, and accurate file mode bits. Initial release.
-rw-r--r--PKGBUILD7
-rw-r--r--aegir-hostmaster.install23
-rw-r--r--aegir.ini8
-rw-r--r--aegir.install24
4 files changed, 35 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e7a9f4dc969..e33817df0540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ url='http://aegirproject.org'
license=('GPL')
depends=(
'aegir-provision'
+ 'cron'
'rsync'
'mariadb'
'sudo'
@@ -23,6 +24,7 @@ optdepends=(
'nginx: for nginx support'
'php-fpm: for nginx support'
)
+install=$pkgname.install
source=(
"http://ftp.drupal.org/files/projects/${_pkgname}-6.x-${pkgver}-core.tar.gz"
'aegir.ini'
@@ -33,7 +35,7 @@ source=(
)
md5sums=(
'381e904e8eed14c9aa574c6ed133d38b'
- '9ea30474db8fa537d2264d422194f01a'
+ '6bd6a1c6264fe7c06d79d1f5159b1e68'
'a849c7594eedec0ef415b972da048815'
'e8b6c3748c26caf4af21d402e7a0b947'
'21178d56a58133e39309dd98d94409cc'
@@ -59,7 +61,8 @@ package() {
msg2 'Adding misc config files'
cd ..
install -Dm644 aegir.ini "${pkgdir}/etc/php/conf.d/10-aegir.ini"
- install -Dm644 nginx.sudoers "${pkgdir}/etc/sudoers.d/aegir-nginx"
+ install -dm750 "${pkgdir}/etc/sudoers.d"
+ install -Dm440 nginx.sudoers "${pkgdir}/etc/sudoers.d/aegir"
install -Dm644 nginx.conf "${pkgdir}/etc/nginx/aegir.conf"
install -Dm644 systemd.service "${pkgdir}/usr/lib/systemd/system/aegir.service"
install -Dm644 nginx.svc.conf "${pkgdir}/usr/lib/systemd/system/nginx.service.d/aegir.conf"
diff --git a/aegir-hostmaster.install b/aegir-hostmaster.install
new file mode 100644
index 000000000000..7aaccdc5706a
--- /dev/null
+++ b/aegir-hostmaster.install
@@ -0,0 +1,23 @@
+post_install() {
+ post_upgrade
+ passwd -l aegir &>/dev/null
+
+ echo ">>> This machine's hostname must be a FQDN that resolves to its IP address."
+ echo ">>> MariaDB must be initialised with:"
+ echo ">>> # /usr/bin/mysql_secure_installation"
+ echo ">>> before Aegir can be used."
+ echo ">>> It's strongly recommended to create a separate, password-protected MySQL"
+ echo ">>> root account for Aegir by running as MySQL root:"
+ echo ">>> # GRANT ALL PRIVILEGES ON *.* TO 'aegir_root'@'%' IDENTIFIED BY "
+ echo ">>> 'password' WITH GRANT OPTION;"
+ echo ">>> $ drush hostmaster-install --web_group=http [--http_service_type=nginx] \\"
+ echo ">>> [--aegir_db_user=root --aegir_db_pass=root] \\"
+ echo ">>> --aegir_host=FQDN [--client_email=email] FQDN"
+}
+
+post_upgrade() {
+ # create user/group that the daemon will run as by default, do not delete this on uninstall, as it will own files
+ getent group aegir >/dev/null || groupadd aegir
+ getent passwd aegir >/dev/null || useradd -g aegir -G http,mail -b '/var/lib' -s /bin/bash aegir
+
+}
diff --git a/aegir.ini b/aegir.ini
index bfa30ef4e8fe..f70793376886 100644
--- a/aegir.ini
+++ b/aegir.ini
@@ -18,7 +18,7 @@ extension=posix.so
; Required config tweaks
;
mbstring.http_input=pass
-mbstring.http_input=pass
+mbstring.http_output=pass
open_basedir =
;
@@ -26,3 +26,9 @@ open_basedir =
;
date.timezone=UTC
memory_limit = 192M
+
+;
+; sendmail options
+;
+;sendmail_path = "/usr/bin/msmtp -C /etc/msmtprc -t" # msmtp
+;sendmail_path = "/usr/bin/sendmail -t" # SSMTP
diff --git a/aegir.install b/aegir.install
deleted file mode 100644
index e80e82ac18d2..000000000000
--- a/aegir.install
+++ /dev/null
@@ -1,24 +0,0 @@
-post_install() {
- post_upgrade
- passwd -l aegir &>/dev/null
-
- echo '>>> This machine's hostname must be a FQDN that resolves to its IP address.'
- echo '>>> MariaDB must be initialised with:'
- echo '>>> # /usr/bin/mysql_secure_installation'
- echo '>>> before Aegir can be used.'
- echo '>>> It's strongly recommended to create a separate, password-protected MySQL'
- echo '>>> root account for Aegir by running as MySQL root:'
- echo ">>> # GRANT ALL PRIVILEGES ON *.* TO 'aegir_root'@'%' IDENTIFIED BY "
- echo ">>> 'password' WITH GRANT OPTION;"
- echo '>>> $ drush hostmaster-install --web_group=http [--http_service_type=nginx] \'
- echo '>>> [--aegir_db_user=root --aegir_db_pass=root] \'
- echo '>>> --aegir_host=FQDN [--client_email=email] FQDN'
-}
-
-post_upgrade() {
- # create user/group that the daemon will run as by default, do not delete this on uninstall, as it will own files
- getent group aegir >/dev/null || groupadd aegir
- getent passwd aegir >/dev/null || useradd -g aegir -b '/var/lib' -s /bin/false aegir
-
- su -c 'drush cc drush' - aegir
-}