summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0tkl2023-07-28 12:44:26 +0800
committer0tkl2023-07-28 12:44:26 +0800
commit6646b21cdbb3783b38b60e61cd0bf7588244c60a (patch)
tree935091d07e2372605677b6d378ee518a7b692f76
parentb1bc07585fc8e6c3d19e75b64c2587bda0f4c711 (diff)
downloadaur-6646b21cdbb3783b38b60e61cd0bf7588244c60a.tar.gz
move necessary VS plugins from optdepends to depends
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD125
2 files changed, 80 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56d5c5f92756..01a92737649c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegisub-arch1t3cht
pkgdesc = A general-purpose subtitle editor with ASS/SSA support (arch1t3cht fork)
pkgver = feature_10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/arch1t3cht/Aegisub
arch = x86_64
license = GPL
@@ -28,13 +28,13 @@ pkgbase = aegisub-arch1t3cht
depends = python
depends = uchardet
depends = vapoursynth
+ depends = vapoursynth-plugin-bestsource
+ depends = vapoursynth-plugin-lsmashsource
+ depends = vapoursynth-plugin-wwxd
depends = wxwidgets-common
depends = wxwidgets-gtk3
depends = zlib
optdepends = avisynthplus: AviSynth source support
- optdepends = vapoursynth-plugin-lsmashsource: VapourSynth plugin used by default (LWLibavSource)
- optdepends = vapoursynth-plugin-bestsource: VapourSynth plugin used by default (BestSource)
- optdepends = vapoursynth-plugin-wwxd: VapourSynth plugin for keyframe generation
optdepends = vapoursynth-plugin-scxvid: VapourSynth plugin for keyframe generation
provides = aegisub
conflicts = aegisub
diff --git a/PKGBUILD b/PKGBUILD
index a8f2e8547d3e..5fd3d7a14012 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,56 +7,78 @@ pkgname=aegisub-arch1t3cht
pkgver=feature_10
_aspver=3.7.3
_vsver=R63
-pkgrel=1
+pkgrel=2
pkgdesc="A general-purpose subtitle editor with ASS/SSA support (arch1t3cht fork)"
-arch=('x86_64')
-url="https://github.com/arch1t3cht/Aegisub"
-license=('GPL' 'BSD')
-provides=('aegisub')
-conflicts=('aegisub' 'aegisub-arch1t3cht-git')
-depends=('alsa-lib'
- 'boost-libs'
- 'ffmpeg'
- 'ffms2'
- 'fftw'
- 'fontconfig'
- 'hicolor-icon-theme'
- 'hunspell'
- 'icu'
- 'jansson'
- 'libass'
- 'libgl'
- 'libpulse'
- 'openal'
- 'portaudio'
- 'python'
- 'uchardet'
- 'vapoursynth'
- 'wxwidgets-common'
- 'wxwidgets-gtk3'
- 'zlib')
-makedepends=('git' 'meson' 'cmake' 'boost')
-optdepends=('avisynthplus: AviSynth source support'
- 'vapoursynth-plugin-lsmashsource: VapourSynth plugin used by default (LWLibavSource)'
- 'vapoursynth-plugin-bestsource: VapourSynth plugin used by default (BestSource)'
- 'vapoursynth-plugin-wwxd: VapourSynth plugin for keyframe generation'
- 'vapoursynth-plugin-scxvid: VapourSynth plugin for keyframe generation')
-source=("$pkgname.tar.gz::https://github.com/arch1t3cht/Aegisub/archive/$pkgver.tar.gz"
- "$pkgname-bestsource::git+https://github.com/vapoursynth/bestsource.git#commit=ba1249c1f5443be6d0ec2be32490af5bbc96bf99"
- "$pkgname-avisynth.tar.gz::https://github.com/AviSynth/AviSynthPlus/archive/v$_aspver.tar.gz"
- "$pkgname-vapoursynth.tar.gz::https://github.com/vapoursynth/vapoursynth/archive/$_vsver.tar.gz"
- "$pkgname-luajit::git+https://github.com/LuaJIT/LuaJIT.git#branch=v2.1"
- "$pkgname-gtest-1.8.1.zip::https://github.com/google/googletest/archive/release-1.8.1.zip"
- "$pkgname-gtest-1.8.1-1-wrap.zip::https://wrapdb.mesonbuild.com/v1/projects/gtest/1.8.1/1/get_zip")
-noextract=("$pkgname-gtest-1.8.1.zip"
- "$pkgname-gtest-1.8.1-1-wrap.zip")
-sha256sums=('9c93b581fe3af3fda2bb9e7e3cddfe209a76d5929ea774515914a1da6d026b5c'
- 'SKIP'
- 'b847705af6f16fa26664d06e0fea2bda14a7f6aac8249a9c37e4106ecb8fd44c'
- 'ed909b3c58e79bcbb056d07c5d301222ba8001222b4b40d5c1123be35fea9ae2'
- 'SKIP'
- '927827c183d01734cc5cfef85e0ff3f5a92ffe6188e0d18e909c5efebf28a0c7'
- 'f79f5fd46e09507b3f2e09a51ea6eb20020effe543335f5aee59f30cc8d15805')
+arch=(x86_64)
+url=https://github.com/arch1t3cht/Aegisub
+license=(
+ GPL
+ BSD
+)
+provides=(aegisub)
+conflicts=(
+ aegisub
+ aegisub-arch1t3cht-git
+)
+depends=(
+ alsa-lib
+ boost-libs
+ ffmpeg
+ ffms2
+ fftw
+ fontconfig
+ hicolor-icon-theme
+ hunspell
+ icu
+ jansson
+ libass
+ libgl
+ libpulse
+ openal
+ portaudio
+ python
+ uchardet
+ vapoursynth
+ vapoursynth-plugin-bestsource
+ vapoursynth-plugin-lsmashsource
+ vapoursynth-plugin-wwxd
+ wxwidgets-common
+ wxwidgets-gtk3
+ zlib
+)
+makedepends=(
+ git
+ meson
+ cmake
+ boost
+)
+optdepends=(
+ 'avisynthplus: AviSynth source support'
+ # 'vapoursynth-plugin-wwxd: VapourSynth plugin for keyframe generation'
+ 'vapoursynth-plugin-scxvid: VapourSynth plugin for keyframe generation'
+)
+source=(
+ "$pkgname.tar.gz::https://github.com/arch1t3cht/Aegisub/archive/$pkgver.tar.gz"
+ "$pkgname-bestsource::git+https://github.com/vapoursynth/bestsource.git#commit=ba1249c1f5443be6d0ec2be32490af5bbc96bf99"
+ "$pkgname-avisynth.tar.gz::https://github.com/AviSynth/AviSynthPlus/archive/v$_aspver.tar.gz"
+ "$pkgname-vapoursynth.tar.gz::https://github.com/vapoursynth/vapoursynth/archive/$_vsver.tar.gz"
+ "$pkgname-luajit::git+https://github.com/LuaJIT/LuaJIT.git#branch=v2.1"
+ "$pkgname-gtest-1.8.1.zip::https://github.com/google/googletest/archive/release-1.8.1.zip"
+ "$pkgname-gtest-1.8.1-1-wrap.zip::https://wrapdb.mesonbuild.com/v1/projects/gtest/1.8.1/1/get_zip"
+)
+noextract=(
+ $pkgname-gtest-1.8.1.zip
+ $pkgname-gtest-1.8.1-1-wrap.zip
+)
+sha256sums=(
+ '9c93b581fe3af3fda2bb9e7e3cddfe209a76d5929ea774515914a1da6d026b5c'
+ 'SKIP'
+ 'b847705af6f16fa26664d06e0fea2bda14a7f6aac8249a9c37e4106ecb8fd44c'
+ 'ed909b3c58e79bcbb056d07c5d301222ba8001222b4b40d5c1123be35fea9ae2'
+ 'SKIP'
+ '927827c183d01734cc5cfef85e0ff3f5a92ffe6188e0d18e909c5efebf28a0c7'
+ 'f79f5fd46e09507b3f2e09a51ea6eb20020effe543335f5aee59f30cc8d15805'
+)
AEGISUB_AUR_DEFAULT_AUDIO_OUTPUT=${AEGISUB_AUR_DEFAULT_AUDIO_OUTPUT:=PulseAudio}
@@ -127,6 +149,11 @@ build() {
meson compile -C build
}
+check() {
+ cd Aegisub-$pkgver
+ meson test -C build --print-errorlogs --verbose "gtest main"
+}
+
package() {
cd Aegisub-$pkgver
meson install -C build --destdir $pkgdir