summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:05:57 +0200
committerMaxime Gauduin2015-06-08 11:06:56 +0200
commit7e1fe9cabb68a7ef8b9f3d285c23606e6f709d23 (patch)
tree2e421956880fca59ce7b55f726c327745a1b3d07
downloadaur-7e1fe9cabb68a7ef8b9f3d285c23606e6f709d23.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD56
-rw-r--r--aegisub.install14
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7ffa1a33b07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = aegisub-git
+ pkgdesc = A general-purpose subtitle editor with ASS/SSA support
+ pkgver = 3.2.2.r165.ba9f5a7
+ pkgrel = 1
+ url = http://www.aegisub.org
+ install = aegisub.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = BSD
+ makedepends = boost
+ makedepends = git
+ makedepends = intltool
+ makedepends = mesa
+ depends = boost-libs
+ depends = desktop-file-utils
+ depends = ffms2
+ depends = fftw
+ depends = hunspell
+ depends = wxgtk
+ optdepends = libpulse: Pulseaudio backend
+ optdepends = openal: OpenAL backend
+ optdepends = oss: OSS backend
+ optdepends = portaudio: Portaudio backend
+ provides = aegisub
+ conflicts = aegisub
+ source = aegisub::git+https://github.com/Aegisub/Aegisub.git
+ source = git+https://github.com/Aegisub/assdraw.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = aegisub-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..e88858eb7751
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('aegisub-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..697b227a3d98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=aegisub-git
+pkgver=3.2.2.r165.ba9f5a7
+pkgrel=1
+pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
+arch=('i686' 'x86_64')
+url='http://www.aegisub.org'
+license=('GPL' 'BSD')
+depends=('boost-libs' 'desktop-file-utils' 'ffms2' 'fftw' 'hunspell' 'wxgtk')
+makedepends=('boost' 'git' 'intltool' 'mesa')
+optdepends=('libpulse: Pulseaudio backend'
+ 'openal: OpenAL backend'
+ 'oss: OSS backend'
+ 'portaudio: Portaudio backend')
+provides=('aegisub')
+conflicts=('aegisub')
+install='aegisub.install'
+source=('aegisub::git+https://github.com/Aegisub/Aegisub.git'
+ 'git+https://github.com/Aegisub/assdraw.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd aegisub
+
+ tag='v3.2.2'
+
+ echo "${tag#v}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd aegisub
+
+ sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
+ ./autogen.sh
+}
+
+build () {
+ cd aegisub
+
+ ./configure \
+ --prefix='/usr'
+ make
+}
+
+package() {
+ cd aegisub
+
+ make DESTDIR="${pkgdir}" install
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses/aegisub-git
+ install -m 644 LICENCE "${pkgdir}"/usr/share/licenses/aegisub-git/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/aegisub.install b/aegisub.install
new file mode 100644
index 000000000000..214da2ef9421
--- /dev/null
+++ b/aegisub.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: