summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2021-12-14 02:09:41 +0100
committerFichteFoll2021-12-14 02:09:41 +0100
commit21468967c8ff889210d9fabe9fba1472aaa3e09d (patch)
treeac554ec98a1077a7ed1927bea1d438e7b9b1fb08
parent1d1f0c09fe7bc603ee730a1f91a17efe4e380f81 (diff)
downloadaur-21468967c8ff889210d9fabe9fba1472aaa3e09d.tar.gz
Support --wrap-mode=nodownload
With meson 0.60, it is now possible to patch a pre-downloaded wrap-git. See also https://github.com/TypesettingTools/Aegisub/issues/113.
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD35
3 files changed, 38 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4b92bb21248..70b3a9dce2c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegisub-ttools-meson-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support (TypesettingTools fork)
- pkgver = 3.2.2.r644.696a73284
- pkgrel = 1
+ pkgver = 3.2.2.r663.f21d8a360
+ pkgrel = 2
url = http://www.aegisub.org
arch = x86_64
license = GPL
@@ -28,8 +28,15 @@ pkgbase = aegisub-ttools-meson-git
provides = aegisub
conflicts = aegisub
conflicts = aegisub-git
+ noextract = gtest-1.8.1.zip
+ noextract = gtest-1.8.1-1-wrap.zip
source = aegisub-ttools::git+https://github.com/TypesettingTools/Aegisub.git
+ source = luajit::git+https://github.com/LuaJIT/LuaJIT.git#branch=v2.1
+ source = gtest-1.8.1.zip::https://github.com/google/googletest/archive/release-1.8.1.zip
+ source = gtest-1.8.1-1-wrap.zip::https://wrapdb.mesonbuild.com/v1/projects/gtest/1.8.1/1/get_zip
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 927827c183d01734cc5cfef85e0ff3f5a92ffe6188e0d18e909c5efebf28a0c7
+ sha256sums = f79f5fd46e09507b3f2e09a51ea6eb20020effe543335f5aee59f30cc8d15805
pkgname = aegisub-ttools-meson-git
-
diff --git a/.gitignore b/.gitignore
index ecdba67ebdb4..7dc6059bc526 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ src/
pkg/
*.pkg.tar*
aegisub-ttools/
+luajit/
diff --git a/PKGBUILD b/PKGBUILD
index 0856d3449929..85918a8cc799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=aegisub-ttools-meson-git
_srcname=aegisub-ttools
-pkgver=3.2.2.r644.696a73284
-pkgrel=1
+pkgver=3.2.2.r663.f21d8a360
+pkgrel=2
pkgdesc='A general-purpose subtitle editor with ASS/SSA support (TypesettingTools fork)'
arch=('x86_64')
url='http://www.aegisub.org'
@@ -20,25 +20,44 @@ makedepends=('boost' 'git' 'intltool' 'lua' 'mesa' 'meson')
# which makes building quite inconvenient over using the vendored one.
provides=('aegisub')
conflicts=('aegisub' 'aegisub-git')
-source=("$_srcname::git+https://github.com/TypesettingTools/Aegisub.git")
-sha256sums=('SKIP')
+source=(
+ "$_srcname::git+https://github.com/TypesettingTools/Aegisub.git"
+ "luajit::git+https://github.com/LuaJIT/LuaJIT.git#branch=v2.1"
+ "gtest-1.8.1.zip::https://github.com/google/googletest/archive/release-1.8.1.zip"
+ "gtest-1.8.1-1-wrap.zip::https://wrapdb.mesonbuild.com/v1/projects/gtest/1.8.1/1/get_zip"
+)
+noextract=(
+ "gtest-1.8.1.zip"
+ "gtest-1.8.1-1-wrap.zip"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ '927827c183d01734cc5cfef85e0ff3f5a92ffe6188e0d18e909c5efebf28a0c7'
+ 'f79f5fd46e09507b3f2e09a51ea6eb20020effe543335f5aee59f30cc8d15805'
+)
pkgver() {
cd "$_srcname"
tag='v3.2.2'
-
echo "${tag#v}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
cd "$_srcname"
+ # Initialize subproject wraps for luajit
+ ln -s ../../luajit subprojects/luajit
+ meson subprojects packagefiles --apply luajit
+ # and gtest
+ mkdir subprojects/packagecache
+ ln -s ../../../gtest-1.8.1.zip subprojects/packagecache/gtest-1.8.1.zip
+ ln -s ../../../gtest-1.8.1-1-wrap.zip subprojects/packagecache/gtest-1.8.1-1-wrap.zip
+
arch-meson builddir \
-Dportaudio=disabled \
- -Dopenal=disabled \
- --wrap-mode=nofallback
- # Must overwrite wrap-mode for luajit, which is 'nodownload' otherwise
+ -Dopenal=disabled
}
build() {