summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2019-11-30 15:01:10 +0100
committerFichteFoll2019-11-30 15:01:10 +0100
commit31fb9d37ce99bca51ae2cacaeb026e9e509ec63a (patch)
tree3e3843d46e9915293f9d11771c4ba56b385d307c
parenta44269ca4773824762d7b9a4baa6384605a899f8 (diff)
downloadaur-31fb9d37ce99bca51ae2cacaeb026e9e509ec63a.tar.gz
Use the TypesettingTools fork and its meson branch
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD52
2 files changed, 36 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a0af97de46d..52fab5385343 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,35 @@
-# Generated by mksrcinfo v8
-# Fri Mar 16 19:33:07 UTC 2018
-pkgbase = aegisub-git
- pkgdesc = A general-purpose subtitle editor with ASS/SSA support
- pkgver = 3.2.2.r323.f6a2ac08a
+pkgbase = aegisub-ttools-meson-git
+ pkgdesc = A general-purpose subtitle editor with ASS/SSA support (TypesettingTools fork, meson branch)
+ pkgver = 3.2.2.r440.9ebfbf456
pkgrel = 1
url = http://www.aegisub.org
arch = x86_64
license = GPL
license = BSD
- makedepends = autoconf-archive
makedepends = boost
makedepends = git
makedepends = intltool
makedepends = lua
makedepends = mesa
- depends = alsa-lib
- depends = boost-libs
- depends = fftw
- depends = fontconfig
+ makedepends = meson
depends = gcc-libs
depends = glibc
- depends = hunspell
+ depends = boost-libs
+ depends = fontconfig
depends = icu
depends = libgl
- depends = libpulse
- depends = uchardet
depends = wxgtk3
depends = zlib
depends = libass.so
+ depends = alsa-lib
depends = libffms2.so
+ depends = fftw
+ depends = hunspell
+ depends = uchardet
provides = aegisub
conflicts = aegisub
- source = aegisub::git+https://github.com/Aegisub/Aegisub.git
- source = git+https://github.com/Aegisub/assdraw.git
- sha256sums = SKIP
+ source = aegisub-ttools::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson
sha256sums = SKIP
-pkgname = aegisub-git
+pkgname = aegisub-ttools-meson-git
diff --git a/PKGBUILD b/PKGBUILD
index eb15438fb9fb..6f58cdd41290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: FichteFoll <fichtefoll2@googlemail.com>
-pkgname=aegisub-git
-pkgver=3.2.2.r323.f6a2ac08a
+pkgname=aegisub-ttools-meson-git
+_srcname=aegisub-ttools
+pkgver=3.2.2.r440.9ebfbf456
pkgrel=1
-pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
+pkgdesc='A general-purpose subtitle editor with ASS/SSA support (TypesettingTools fork, meson branch)'
arch=('x86_64')
url='http://www.aegisub.org'
license=('GPL' 'BSD')
-depends=('alsa-lib' 'boost-libs' 'fftw' 'fontconfig' 'gcc-libs' 'glibc'
- 'hunspell' 'icu' 'libgl' 'libpulse' 'uchardet' 'wxgtk3' 'zlib'
- 'libass.so' 'libffms2.so')
-makedepends=('autoconf-archive' 'boost' 'git' 'intltool' 'lua' 'mesa')
+depends=('gcc-libs' 'glibc' 'boost-libs'
+ 'fontconfig' 'icu' 'libgl' 'wxgtk3' 'zlib' 'libass.so'
+ # optional by the build system, but don't make much sense to exclude
+ 'alsa-lib' 'libffms2.so' 'fftw' 'hunspell' 'uchardet'
+ # 'luajit' # Arch's luajit isn't compiled in 5.2 mode
+ ) # I think it depends on something else here too, but not sure what
+makedepends=('boost' 'git' 'intltool' 'lua' 'mesa' 'meson')
provides=('aegisub')
conflicts=('aegisub')
-source=('aegisub::git+https://github.com/Aegisub/Aegisub.git'
- 'git+https://github.com/Aegisub/assdraw.git')
-sha256sums=('SKIP'
- 'SKIP')
+source=("$_srcname::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson")
+sha256sums=('SKIP')
pkgver() {
- cd aegisub
+ cd "$_srcname"
tag='v3.2.2'
@@ -27,31 +29,25 @@ pkgver() {
}
prepare() {
- cd aegisub
- sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
+ cd "$_srcname"
- cp -f /usr/share/aclocal/ax_boost_{chrono,filesystem,locale,regex,system,thread}.m4 m4macros/
+ #patch -p1 < ../fix_version.patch
- ./autogen.sh
+ arch-meson builddir -Dportaudio=disabled -Dopenal=disabled
}
build() {
- cd aegisub
-
- ./configure \
- --prefix='/usr' \
- --with-wx-config='/usr/bin/wx-config-gtk3' \
- --without-{portaudio,openal,oss} \
- --disable-update-checker
- make
+ cd "$_srcname"
+
+ ninja -C builddir
}
package() {
- cd aegisub
+ cd "$_srcname"
- make DESTDIR="${pkgdir}" install
- install -Dm 644 LICENCE -t "${pkgdir}"/usr/share/licenses/aegisub-git/
+ DESTDIR="${pkgdir}" ninja -C builddir install
+ install -Dm 644 LICENCE -t "${pkgdir}/usr/share/licenses/$pkgname/"
}
# vim: ts=2 sw=2 et: