summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2020-12-07 23:50:12 +0100
committerFichteFoll2020-12-07 23:50:12 +0100
commitbe2dc711587239b8ba96efdde17915fb80f5c88d (patch)
tree396024e3afec71f709068bb3df77ed5844586a4a
parentbe779ef8fda13391e3a7130440240aab8b0c1f3d (diff)
downloadaur-be2dc711587239b8ba96efdde17915fb80f5c88d.tar.gz
Drop now redundant patch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--fix_audio_cache.patch41
3 files changed, 6 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 971612594bc6..a9737bb745ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegisub-ttools-meson-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support (TypesettingTools fork, meson branch)
- pkgver = 3.2.2.r441.8b0aaaf7e
- pkgrel = 2
+ pkgver = 3.2.2.r491.53034e5f8
+ pkgrel = 1
url = http://www.aegisub.org
arch = x86_64
license = GPL
@@ -24,13 +24,12 @@ pkgbase = aegisub-ttools-meson-git
depends = fftw
depends = hunspell
depends = uchardet
+ depends = glibc
provides = aegisub
conflicts = aegisub
conflicts = aegisub-git
- source = aegisub-ttools::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson
- source = fix_audio_cache.patch
+ source = aegisub-ttools::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson-vs2019
sha256sums = SKIP
- sha256sums = 5771cca865098c69a7fe269c30999c84a3a0f90ed0b55c80ec8df61975702a93
pkgname = aegisub-ttools-meson-git
diff --git a/PKGBUILD b/PKGBUILD
index 0589f282842d..415e3d7a7e33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,8 @@ makedepends=('boost' 'git' 'intltool' 'lua' 'mesa' 'meson')
# which makes building quite inconvenient over using the vendored one.
provides=('aegisub')
conflicts=('aegisub' 'aegisub-git')
-source=("$_srcname::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson-vs2019"
- "fix_audio_cache.patch")
-sha256sums=('SKIP'
- '3ddbc863fba016c664d8bcec377c567e8641072c7156a69bca87b6536f8a7016')
+source=("$_srcname::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson-vs2019")
+sha256sums=('SKIP')
pkgver() {
cd "$_srcname"
@@ -37,7 +35,6 @@ prepare() {
cd "$_srcname"
- patch -p1 < ../fix_audio_cache.patch
arch-meson builddir -Dportaudio=disabled -Dopenal=disabled
}
diff --git a/fix_audio_cache.patch b/fix_audio_cache.patch
deleted file mode 100644
index b744d119a5e8..000000000000
--- a/fix_audio_cache.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 1c6999b33a1b66b46143266ba9f842a32e837484 Mon Sep 17 00:00:00 2001
-From: Myaamori <myaamori1993@gmail.com>
-Date: Thu, 21 May 2020 05:11:15 +0100
-Subject: [PATCH] Fix mutation while iterating corrupting linked list in
- block_cache.h
-
----
- src/block_cache.h | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/src/block_cache.h b/src/block_cache.h
-index f2ebfa261..4025dac11 100644
---- a/src/block_cache.h
-+++ b/src/block_cache.h
-@@ -91,7 +91,6 @@ class DataBlockCache {
- size -= (ba.size() - std::count(ba.begin(), ba.end(), nullptr)) * factory.GetBlockSize();
-
- ba.clear();
-- age.erase(mb.position);
- }
-
- public:
-@@ -150,8 +149,16 @@
- }
-
- // Remove old entries until we're under the max size
-- for (auto it = age.rbegin(); size > max_size && it != age.rend(); it++)
-- KillMacroBlock(**it);
-+ auto it = age.end();
-+ while (size > max_size) {
-+ if (it == age.begin())
-+ break;
-+ it--;
-+ KillMacroBlock(**it);
-+ }
-+
-+ while (it != age.end())
-+ it = age.erase(it);
- }
-
- /// @brief Obtain a data block from the cache \ No newline at end of file