summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2020-12-07 23:42:07 +0100
committerFichteFoll2020-12-07 23:42:07 +0100
commitbe779ef8fda13391e3a7130440240aab8b0c1f3d (patch)
tree1e3686402259a005bc66e4b984913f075be432bf
parenta2d437812518c5193b48f5cb255482e905673b4a (diff)
downloadaur-be779ef8fda13391e3a7130440240aab8b0c1f3d.tar.gz
Fix changed upstream branch & patch
-rw-r--r--PKGBUILD17
-rw-r--r--fix_audio_cache.patch12
2 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da4867b9a761..0589f282842d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=aegisub-ttools-meson-git
_srcname=aegisub-ttools
-pkgver=3.2.2.r441.8b0aaaf7e
-pkgrel=2
+pkgver=3.2.2.r491.53034e5f8
+pkgrel=1
pkgdesc='A general-purpose subtitle editor with ASS/SSA support (TypesettingTools fork, meson branch)'
arch=('x86_64')
url='http://www.aegisub.org'
@@ -11,22 +11,19 @@ license=('GPL' 'BSD')
depends=('boost-libs'
'fontconfig' 'icu' 'libgl' 'wxgtk3' 'zlib' 'libass.so'
# optional by the build system, but don't make much sense to exclude
- 'alsa-lib' 'libffms2.so' 'fftw' 'hunspell' 'uchardet'
+ 'alsa-lib' 'libffms2.so' 'fftw' 'hunspell' 'uchardet' 'glibc'
# 'gcc-libs' 'glibc' # part of 'base'
# 'luajit' # Arch's luajit isn't compiled in 5.2 mode
)
makedepends=('boost' 'git' 'intltool' 'lua' 'mesa' 'meson')
+# 'libiconv' is on the AUR, but uses an expired GPG signing key,
+# which makes building quite inconvenient over using the vendored one.
provides=('aegisub')
conflicts=('aegisub' 'aegisub-git')
-source=("$_srcname::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson"
+source=("$_srcname::git+https://github.com/TypesettingTools/Aegisub.git#branch=meson-vs2019"
"fix_audio_cache.patch")
sha256sums=('SKIP'
- '5771cca865098c69a7fe269c30999c84a3a0f90ed0b55c80ec8df61975702a93')
-
-# TODO check libiconv dep
-# "had to install libiconv manually though since it's not listed as a dependency
-# I believe it's an optional dependency
-# meson still configures with it"
+ '3ddbc863fba016c664d8bcec377c567e8641072c7156a69bca87b6536f8a7016')
pkgver() {
cd "$_srcname"
diff --git a/fix_audio_cache.patch b/fix_audio_cache.patch
index f91247d315c1..b744d119a5e8 100644
--- a/fix_audio_cache.patch
+++ b/fix_audio_cache.patch
@@ -20,12 +20,12 @@ index f2ebfa261..4025dac11 100644
}
public:
-@@ -150,8 +150,16 @@
+@@ -150,8 +149,16 @@
}
-
+
// Remove old entries until we're under the max size
-- for (auto it = age.rbegin(); size > max_size && it != age.rend(); )
-- KillMacroBlock(**it++);
+- for (auto it = age.rbegin(); size > max_size && it != age.rend(); it++)
+- KillMacroBlock(**it);
+ auto it = age.end();
+ while (size > max_size) {
+ if (it == age.begin())
@@ -37,5 +37,5 @@ index f2ebfa261..4025dac11 100644
+ while (it != age.end())
+ it = age.erase(it);
}
-
- /// @brief Obtain a data block from the cache
+
+ /// @brief Obtain a data block from the cache \ No newline at end of file