summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-06-05 21:30:45 +0200
committerMaxime Gauduin2017-06-05 21:30:45 +0200
commitf9b3fb6ea4e33d0aa60e994def5920891c2c9cd7 (patch)
tree18d3f5747ab9bfdce675389ae82ff50642357ac5
parentbff4a25b50aa20ae2f7fd1a88a88f963ba82a27f (diff)
downloadaur-f9b3fb6ea4e33d0aa60e994def5920891c2c9cd7.tar.gz
aegisub-git 3.2.2.r305.8d3ad9ff6-1
Switch to wxgtk3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2770a99678ee..171fa4059d30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed May 3 19:40:29 UTC 2017
+# Mon Jun 5 19:30:44 UTC 2017
pkgbase = aegisub-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support
- pkgver = 3.2.2.r303.3594ade71
+ pkgver = 3.2.2.r305.8d3ad9ff6
pkgrel = 1
url = http://www.aegisub.org
arch = i686
@@ -16,7 +16,6 @@ pkgbase = aegisub-git
makedepends = mesa
depends = alsa-lib
depends = boost-libs
- depends = desktop-file-utils
depends = fftw
depends = fontconfig
depends = gcc-libs
@@ -24,22 +23,18 @@ pkgbase = aegisub-git
depends = hunspell
depends = icu
depends = libgl
- depends = wxgtk
+ depends = libpulse
+ depends = uchardet
+ depends = wxgtk3
depends = zlib
depends = libass.so
depends = libffms2.so
- optdepends = libpulse: Pulseaudio backend
- optdepends = openal: OpenAL backend
- optdepends = oss: OSS backend
- optdepends = portaudio: Portaudio backend
provides = aegisub
conflicts = aegisub
source = aegisub::git+https://github.com/Aegisub/Aegisub.git
source = git+https://github.com/Aegisub/assdraw.git
- source = aegisub-icu59.1.patch::https://github.com/alucryd/Aegisub/commit/d8c69f57f7fbcea47e61381a14987856eefb5fbd.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 1e54d36f6be86d45f13b43f9823786ed7274bb2ff7e71cc0d9270de082757df3
pkgname = aegisub-git
diff --git a/PKGBUILD b/PKGBUILD
index b9e84469a2ee..dda8ea9f27cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=aegisub-git
-pkgver=3.2.2.r303.3594ade71
+pkgver=3.2.2.r305.8d3ad9ff6
pkgrel=1
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=('i686' 'x86_64')
url='http://www.aegisub.org'
license=('GPL' 'BSD')
-depends=('alsa-lib' 'boost-libs' 'desktop-file-utils' 'fftw' 'fontconfig'
- 'gcc-libs' 'glibc' 'hunspell' 'icu' 'libgl' 'wxgtk' 'zlib'
+depends=('alsa-lib' 'boost-libs' 'fftw' 'fontconfig' 'gcc-libs' 'glibc'
+ 'hunspell' 'icu' 'libgl' 'libpulse' 'uchardet' 'wxgtk3' 'zlib'
'libass.so' 'libffms2.so')
makedepends=('boost' 'git' 'intltool' 'lua' 'mesa')
-optdepends=('libpulse: Pulseaudio backend'
- 'openal: OpenAL backend'
- 'oss: OSS backend'
- 'portaudio: Portaudio backend')
provides=('aegisub')
conflicts=('aegisub')
source=('aegisub::git+https://github.com/Aegisub/Aegisub.git'
- 'git+https://github.com/Aegisub/assdraw.git'
- 'aegisub-icu59.1.patch::https://github.com/alucryd/Aegisub/commit/d8c69f57f7fbcea47e61381a14987856eefb5fbd.patch')
+ 'git+https://github.com/Aegisub/assdraw.git')
sha256sums=('SKIP'
- 'SKIP'
- '1e54d36f6be86d45f13b43f9823786ed7274bb2ff7e71cc0d9270de082757df3')
+ 'SKIP')
pkgver() {
cd aegisub
@@ -35,17 +29,19 @@ pkgver() {
prepare() {
cd aegisub
- patch -Np1 -i ../aegisub-icu59.1.patch
-
sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
+
./autogen.sh
+ ./configure \
+ --prefix='/usr' \
+ --with-wx-config='/usr/bin/wx-config-gtk3' \
+ --without-{portaudio,openal,oss} \
+ --disable-update-checker
}
-build () {
+build() {
cd aegisub
- ./configure \
- --prefix='/usr'
make
}
@@ -53,9 +49,7 @@ package() {
cd aegisub
make DESTDIR="${pkgdir}" install
-
- install -dm 755 "${pkgdir}"/usr/share/licenses/aegisub-git
- install -m 644 LICENCE "${pkgdir}"/usr/share/licenses/aegisub-git/
+ install -Dm 644 LICENCE -t "${pkgdir}"/usr/share/licenses/aegisub-git/
}
# vim: ts=2 sw=2 et: