summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusee Ullah2023-10-26 16:34:58 +0900
committerMusee Ullah2023-10-26 16:34:58 +0900
commit71eb5ebfd477f4057f68013c95e5b3ea10f4d122 (patch)
tree0f529efc183469874e315c562131c8946b34e4f7
parenta59fcfbb24d8a61abcea0b2d6a213e6a9ad5a5dc (diff)
downloadaur-71eb5ebfd477f4057f68013c95e5b3ea10f4d122.tar.gz
upgpkg: aegisub-wangqr-git 3.3.3.r2.33ff9b408-1
Fix boost build failure and merge with [extra] package avisynthplus is still retained as a dependency as it appears to be in use as an AV provider if it exists (otherwise it errors out)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD50
-rw-r--r--boost-1.81.0.patch56
3 files changed, 79 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dc9c479e268..204899af4968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = aegisub-wangqr-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support (wangqr fork)
- pkgver = 3.3.3.r1.db3cdded8
+ pkgver = 3.3.3.r2.33ff9b408
pkgrel = 1
url = http://www.aegisub.org
arch = x86_64
license = GPL
license = BSD
- makedepends = autoconf-archive
makedepends = boost
makedepends = cmake
makedepends = git
- makedepends = intltool
- makedepends = lua
makedepends = mesa
+ makedepends = ninja
depends = alsa-lib
depends = avisynthplus
depends = boost-libs
@@ -24,13 +22,15 @@ pkgbase = aegisub-wangqr-git
depends = libffms2.so
depends = libgl
depends = libpulse
- depends = wxwidgets-gtk3
depends = uchardet
+ depends = wxwidgets-gtk3
depends = zlib
provides = aegisub
conflicts = aegisub
conflicts = aegisub-git
source = git+https://github.com/wangqr/Aegisub.git
- sha256sums = SKIP
+ source = boost-1.81.0.patch
+ b2sums = SKIP
+ b2sums = 5b6874ebb89f6ed3ab7929796bd1f59e1748c418ae5397df265fe3007d9f971eec7388f5f6a2dcac020d71c9cffece931a1ae5eb78f8ff4ab61fdc4c5e65328a
pkgname = aegisub-wangqr-git
diff --git a/PKGBUILD b/PKGBUILD
index 0f0b56e079b3..6e4f09835294 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=aegisub-wangqr-git
_pkgtag='v3.3.3'
-pkgver=3.3.3.r1.db3cdded8
+pkgver=3.3.3.r2.33ff9b408
pkgrel=1
pkgdesc='A general-purpose subtitle editor with ASS/SSA support (wangqr fork)'
arch=(x86_64)
@@ -25,26 +25,26 @@ depends=(
libffms2.so
libgl
libpulse
- wxwidgets-gtk3
uchardet
+ wxwidgets-gtk3
zlib
)
makedepends=(
- autoconf-archive
boost
cmake
git
- intltool
- lua
mesa
+ ninja
)
provides=(aegisub)
conflicts=(aegisub aegisub-git)
source=(
git+https://github.com/wangqr/Aegisub.git
+ boost-1.81.0.patch
)
-sha256sums=(
- SKIP
+b2sums=(
+ 'SKIP'
+ '5b6874ebb89f6ed3ab7929796bd1f59e1748c418ae5397df265fe3007d9f971eec7388f5f6a2dcac020d71c9cffece931a1ae5eb78f8ff4ab61fdc4c5e65328a'
)
pkgver() {
@@ -53,43 +53,27 @@ pkgver() {
}
prepare() {
- mkdir -vp build/
cd Aegisub
- # Ensures Aegisub runs under Xwayland, since it doesn't support Wayland properly
- sed 's/^Exec=/Exec=env GDK_BACKEND=x11 /' -i packages/desktop/aegisub.desktop.template.in
+ patch -Np1 -i ../boost-1.81.0.patch # Patch from Gentoo/[extra] aegisub package
}
build() {
- cd build
-
- cmake \
+ cmake -S Aegisub -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
- -DWITH_STARTUPLOG=OFF \
- -DWITH_{PORTAUDIO,OPENAL,OSS}=OFF \
- ../Aegisub
+ -DWITH_OSS=OFF
+ cmake --build build
# TODO: Build translations
}
package() {
- cd "${srcdir}/build"
-
- make DESTDIR="${pkgdir}" install
-
- cd "${srcdir}/Aegisub"
- install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="${pkgdir}" cmake --install build
- cd "${srcdir}/Aegisub/automation/"
- for subdir in {autoload,demos,include,include/aegisub}
- do
- install -dm 755 "${pkgdir}/usr/share/aegisub/automation/${subdir}"
- for resource in $(find ${subdir} -maxdepth 1 -type f)
- do
- install -m 644 "${resource}" "${pkgdir}/usr/share/aegisub/automation/${resource}"
- done
- done
+ install -dm 755 "${pkgdir}"/usr/share/aegisub/automation/include
+ cp -dr --no-preserve=ownership Aegisub/automation/{autoload,demos} "${pkgdir}"/usr/share/aegisub/automation/
+ cp -dr --no-preserve=ownership Aegisub/automation/include/{aegisub,*.lua} "${pkgdir}"/usr/share/aegisub/automation/include/
+ install -Dm 644 Aegisub/LICENCE -t "${pkgdir}"/usr/share/licenses/aegisub/
}
# vim: ts=2 sw=2 et:
diff --git a/boost-1.81.0.patch b/boost-1.81.0.patch
new file mode 100644
index 000000000000..ac264bc70676
--- /dev/null
+++ b/boost-1.81.0.patch
@@ -0,0 +1,56 @@
+diff --git a/libaegisub/include/libaegisub/lua/utils.h b/libaegisub/include/libaegisub/lua/utils.h
+index c5a65d6e4..f4921d582 100644
+--- a/libaegisub/include/libaegisub/lua/utils.h
++++ b/libaegisub/include/libaegisub/lua/utils.h
+@@ -87,7 +87,10 @@ int exception_wrapper(lua_State *L) {
+
+ template<typename T>
+ void set_field(lua_State *L, const char *name, T value) {
+- push_value(L, value);
++ if constexpr(std::is_convertible<T, std::string>::value)
++ push_value(L, static_cast<std::string>(value));
++ else
++ push_value(L, value);
+ lua_setfield(L, -2, name);
+ }
+
+diff --git a/src/auto4_lua.cpp b/src/auto4_lua.cpp
+index 245689679..6d479b2c3 100644
+--- a/src/auto4_lua.cpp
++++ b/src/auto4_lua.cpp
+@@ -115,7 +115,8 @@ namespace {
+ int get_translation(lua_State *L)
+ {
+ wxString str(check_wxstring(L, 1));
+- push_value(L, _(str).utf8_str());
++ const char* val = static_cast<const char*>( _(str).utf8_str());
++ push_value(L, val);
+ return 1;
+ }
+
+diff --git a/src/command/video.cpp b/src/command/video.cpp
+index fb2bcb0ba..77e3e9ca7 100644
+--- a/src/command/video.cpp
++++ b/src/command/video.cpp
+@@ -475,7 +475,7 @@ static void save_snapshot(agi::Context *c, bool raw) {
+ // If where ever that is isn't defined, we can't save there
+ if ((basepath == "\\") || (basepath == "/")) {
+ // So save to the current user's home dir instead
+- basepath = wxGetHomeDir().c_str();
++ basepath = static_cast<const char*>(wxGetHomeDir().c_str());
+ }
+ }
+ // Actual fixed (possibly relative) path, decode it
+diff --git a/src/dialog_attachments.cpp b/src/dialog_attachments.cpp
+index 38ff53027..e30339f81 100644
+--- a/src/dialog_attachments.cpp
++++ b/src/dialog_attachments.cpp
+@@ -161,7 +161,7 @@ void DialogAttachments::OnExtract(wxCommandEvent &) {
+
+ // Multiple or single?
+ if (listView->GetNextSelected(i) != -1)
+- path = wxDirSelector(_("Select the path to save the files to:"), to_wx(OPT_GET("Path/Fonts Collector Destination")->GetString())).c_str();
++ path = static_cast<const char*>(wxDirSelector(_("Select the path to save the files to:"), to_wx(OPT_GET("Path/Fonts Collector Destination")->GetString())).c_str());
+ else {
+ path = SaveFileSelector(
+ _("Select the path to save the file to:"),